Last Comment Bug 200878 - Mozilla hangs after bookmarks is dragged to folder at bottom of list
: Mozilla hangs after bookmarks is dragged to folder at bottom of list
Status: RESOLVED DUPLICATE of bug 201077
: hang
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- critical (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: Chris Petersen
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-05 22:37 PST by Tom Schneider
Modified: 2004-11-22 17:25 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Sampler report captured from FizzillaMach/2003040103 during hang (36.29 KB, text/plain)
2003-04-06 11:09 PDT, Greg K.
no flags Details
Screen shot of scrolling before Mozilla hangs (comment #5) (152.18 KB, image/jpeg)
2003-04-12 12:11 PDT, Ambrose Li
no flags Details

Description Tom Schneider 2003-04-05 22:37:00 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401

I have a set of bookmarks, two normal urls and these are followed
by a folder that I just made (so it is empty).  When i try to move
the bookmarks into the folder mozilla 1.4 hangs.

Reproducible: Always

Steps to Reproduce:
1. capture url
2. create folder at end of bookmark list
3. try to put url into folder
Actual Results:  
mozilla hangs (spinning color wheel on OSX)

Expected Results:  
moved the url into the folder instantly.
Comment 1 Greg K. 2003-04-06 11:08:36 PDT
Confirmed using FizzillaMach/2003040103. Curiously, the Dock refuses clicks
during this hang, though it animates fine.
Comment 2 Greg K. 2003-04-06 11:09:30 PDT
Created attachment 119614 [details]
Sampler report captured from FizzillaMach/2003040103 during hang
Comment 3 Ambrose Li 2003-04-12 09:21:40 PDT
Does it matter how many URL's you are dragging to the bottom? I am wondering if
I am seeing the same bug or a different one: I am noticing this on my Linux
system, but Mozilla only hangs if I drag 4 or more bookmarks (3 at the top
outside the window's visible area, 1 at the bottom - I haven't checked if it
hangs if all the 4 bookmarks can be seen when I drag them); Mozilla doesn't hang
if I drag 3 or less bookmarks to the bottom.
Comment 4 Tom Schneider 2003-04-12 09:42:20 PDT
Surprisingly, moving a set of three urls to a bottom folder did not 
kill Mozilla under Mac OSX.

However when I had one URL already in the folder and moved another, it 
would be ok if the folder was *open*.  If I then moved the urls out
(above) and closed the folder, moving killed.    

By the way, there is a distinct pause of 1 to 2 seconds after moving
the url, then the arrow pointer turns to a spinning wheel and the
Force Quit Applications shows Mozilla in red.  Somehow the system
knows it is hung!
Comment 5 Ambrose Li 2003-04-12 12:08:29 PDT
I probably did not write clearly enough; in my case moving a set of 3 URL's
doesn't hang Mozilla; it hangs only when I move 4 or more.

BTW, I just discovered that, if my target folder is at the very bottom, and I am
moving a large set of URL's, the bookmarks will scroll. They will scroll a while
making some URL's in the top of the window identical, and then it will hang.
(This does not happen if the target folder is not too near the end of the list.)
Comment 6 Ambrose Li 2003-04-12 12:11:05 PDT
Created attachment 120326 [details]
Screen shot of scrolling before Mozilla hangs (comment #5)
Comment 7 sonuva bicz 2003-04-18 09:45:19 PDT
I first noticed this in Phoenix 20030411 build on Windows XP. I just downloaded
and reproduced it in Mozilla 20030418.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030411 Phoenix/0.5+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030418

It freezes/hangs regardless how many bookmarks I'm dragging.
Comment 8 Jan Varga [:janv] 2003-04-20 04:21:01 PDT
I have a patch attached to bug 201077.
Sébastien, thanks for the dupe pointer.
Also thanks for the sampler report.


*** This bug has been marked as a duplicate of 201077 ***

Note You need to log in before you can comment on or make changes to this bug.