Crash inspecting css rule for page which is no longer loaded [@ nsCSSSelector::ToString]

VERIFIED DUPLICATE of bug 111411

Status

()

--
critical
VERIFIED DUPLICATE of bug 111411
16 years ago
16 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({crash, testcase})

Trunk
x86
Windows 2000
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
ok. steps
load data:text/html,<a href="b">c
focus the page
ctrl-shift-i (inspector)
select the 'a' node
view css style rules
select one of them
in navigator load another page
in inspector click on of the other rules
<crash>

Incident ID 18846409
Stack Signature         nsCSSSelector::ToString 60e00f5c
Product ID      MozillaTrunk
Build ID        2003032608
Operating System        Windows NT 5.0 build 2195
Module  gklayout.dll
Trigger Reason  Access violation
Source File Name       
c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleRule.cpp
Trigger Line No.        630
Stack Trace

nsCSSSelector::ToString
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleRule.cpp, line 630]
CSSStyleRuleImpl::GetSelectorText
[c:/builds/seamonkey/mozilla/content/html/style/src/nsCSSStyleRule.cpp, line 2
268]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2025]
XPC_WN_GetterSetter
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1325]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 845]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 936]
js_InternalGetOrSet [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 962]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2552]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2663]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 861]
nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 13
34]
nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 429]
PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 119]
SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 147]
nsTreeBodyFrame::PaintText
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2
822]
nsTreeBodyFrame::PaintCell
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2
608]
nsTreeBodyFrame::PaintRow
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 24
23]
nsTreeBodyFrame::Paint
[c:/builds/seamonkey/mozilla/layout/xul/base/src/tree/src/nsTreeBodyFrame.cpp,
line 2206]
PresShell::Paint
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 5815]
nsView::Paint [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 283]
nsViewManager::RenderDisplayListElement
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1249]
nsViewManager::RenderViews
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1198]
nsViewManager::Refresh [c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp,
line 790]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1796]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1154]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1176]
nsWindow::OnPaint [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp,
line 5236]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3929]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1438]
USER32.dll + 0x3eb0 (0x77e13eb0)
USER32.dll + 0x591b (0x77e1591b)
USER32.dll + 0x595d (0x77e1595d)
ntdll.dll + 0x1fb83 (0x77f9fb83)
USER32.dll + 0x3f0f (0x77e13f0f)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 480]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1287]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1645]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1666]
WinMainCRTStartup()
KERNEL32.DLL + 0x7903 (0x77e87903)
(Reporter)

Comment 1

16 years ago
*** Bug 200888 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: testcase
This is a known bug in Inspector -- inspecting style info in that pane should
not be done after the ruletree has been blown away.  

*** This bug has been marked as a duplicate of 111411 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
(Reporter)

Comment 3

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
Crash Signature: [@ nsCSSSelector::ToString]
You need to log in before you can comment on or make changes to this bug.