Responding to a message sets previous 'to' recipients as 'cc' recipients

NEW
Unassigned

Status

MailNews Core
Composition
--
enhancement
15 years ago
8 years ago

People

(Reporter: Olivier Vit (just a reporter), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

recipients change from 'to' to 'cc' when doing a reply to

Reproducible: Always

Steps to Reproduce:
You receive a message from A with B,C,D in 'to', and X,Y,Z in 'cc'
You reply to this message


Actual Results:  
Then only A is 'to'
And all B,C,D,X,Y,Z become 'cc'

Expected Results:  
Logically, the position of the recipients regarding the message and its purpose
shouldn't change when you reply to the original message: B,C,D should stay as 'to'
(Reporter)

Comment 1

15 years ago
Still true with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b)
Gecko/20030507
Severity: enhancement → major
Summary: responding to a message set previous 'to' recipients as 'cc' recipients → Responding to a message sets previous 'to' recipients as 'cc' recipients

Comment 2

15 years ago
This is not a bug - most MUAs behave the same way AFAIK. Is you think about it,
this is reasonable - the response is TO whomever wrote the original message and
CC other recepients of the original message.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

15 years ago
I don't agree with comments #2
May be other MUA act this way, but the way people (like in large organisations
or when multiple organisations are working together) are now distinguishing TO
and CC implies that this quality of the relationship with the message is being
preserved through the different replies.

This is even more true when you happen you reply to a message you sent yourself:
you don't want to set again by hand who is TO and who is CC, especially when you
have 20 recipients or more

Qualifiying as enhancement request at least !

PS : By extension, this should also taken into account in address book lists
(who should to and cc by default), but it's another story !
Severity: major → enhancement
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Product: MailNews → Core
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 5

13 years ago
Still a valid enhancement request

Updated

13 years ago
Assignee: ducarroz → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: esther
Hardware: PC → All

Updated

10 years ago
QA Contact: composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 6

8 years ago
(In reply to comment #2)
> This is not a bug - most MUAs behave the same way AFAIK. Is you think about it,
> this is reasonable - the response is TO whomever wrote the original message and
> CC other recepients of the original message.

are there specs on how this should behave?
You need to log in before you can comment on or make changes to this bug.