Crash when starting up Firebird

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: André Lemos, Assigned: Blake Ross)

Tracking

({crash, qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Need to reproduce)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030322
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030322

(gdb) run
Starting program: /usr/lib/phoenix/phoenix-bin
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384
(LWP 9808)]
 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 32769 (LWP 9810)]
[New Thread 16386 (LWP 9811)]
[New Thread 32771 (LWP 9812)]
[New Thread 49156 (LWP 9813)]
 
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 9808)]
0x41924abc in NSGetModule () from /usr/lib/phoenix/components/libdocshell.so
(gdb)



(Using phoenix-cvs)

Reproducible: Always

Steps to Reproduce:
Can you give steps to reproduce? How did this crash occur?
(Reporter)

Comment 2

15 years ago
Sorry for the delay, but I wasn't on the CC list.

After getting the latest cvs, when I run phoenix I always get that error.

I'll continue to cvs update -d, maybe I'll get lucky :-(
(Reporter)

Comment 3

15 years ago
Today I got a different crash, much less verbose :-(

(gdb) run
Starting program: /usr/lib/phoenix/phoenix-bin
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384
(LWP 26889)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...
(no debugging symbols found)...(no debugging symbols found)...(no debugging
symbols found)...[New Thread 32769 (LWP 26891)]
[New Thread 16386 (LWP 26892)]
[New Thread 32771 (LWP 26893)]
[New Thread 49156 (LWP 26894)]
 
Program exited with code 01.



Dunno what code 01 is.
(Reporter)

Comment 4

15 years ago
(gdb) run
Starting program: /usr/lib/phoenix/phoenix-bin
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384
(LWP 3422)]
 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
 
(phoenix-bin:3422): Gdk-WARNING **: locale not supported by Xlib
 
(phoenix-bin:3422): Gdk-WARNING **: can not set locale modifiers
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
---Type <return> to continue, or q <return> to quit---
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 32769
(LWP 3427)]
[New Thread 16386 (LWP 3428)]
[New Thread 32771 (LWP 3429)]
 
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 49156 (LWP 3430)]
 
Program exited with code 01.


I keep on getting the same error.... Si no thoughts? At least for debuging?

Comment 5

15 years ago
Andre, I changed the summary a bit to reflect the actual problem. Also I added
keywords "crash" and "qawanted" so perhaps someone with Linux & CVS experience
comes in and tracks the problem down. As I neither don't use Linux nor did I
ever compiled Firebird myself I can't help you with that...

btw: this is no "blocker" => changed severity to at most "critical". 
Severity: blocker → critical
Keywords: crash, qawanted
Summary: 0x41924abc in NSGetModule () from /usr/lib/phoenix/components/libdocshell.so → Crash when starting up Firebird
(Reporter)

Comment 6

15 years ago
It is blocker to me ;-)

Thanks for the changes

Updated

15 years ago
Whiteboard: Need to reproduce

Comment 7

15 years ago
Andre,

This is from http://www.mozilla.org/build/unix.html

To pull or update the tree without building,

      gmake -f client.mk checkout 

Important: Do not use cvs update! Not only will it pull lots of files which you
won't want or need but, because mozilla uses several separately tagged modules,
you may end up with the wrong versions of files

The important part is 'Do not use cvs update'.  I have a feeling that this may
be your problem.

Comment 8

15 years ago
Andre, as noone else seem to have this problem I suppose this not to be a bug
within Mozilla Firebird.
Hence I'll resolve this bug "WFM" and suggest opening a thread in either a
related newsgroup or perhaps you want the forums @MozillaZine
(http://www.mozillazine.org/forums/viewforum.php?f=7) give it a try.

If you find this problem to be caused by Mozilla Firebird feel free to reopen
this bug report!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

15 years ago
I'd just like to say to Robert, that I've deleted the cvs tree I had and
refetched everything and recompiled having the same results.

Thanks either way
You need to log in before you can comment on or make changes to this bug.