In Bookmark Manager, Redo (Ctrl+Y) fails, acting as undelete at least. [v1.4rc1: disabled feature !]

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: sgautherie, Assigned: bugs)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401

Impossible to undelete using Redo !


Reproducible: Always

Steps to Reproduce:
0. Add 1+ dumb entry (bookmark, folder, separator, ...)
1. Delete it
2. Redo (Ctrl+Y)

Actual Results:  
Nothing happens; even repeating step 2.



Could this be related to bug 160019  ?

(See also related (Phoenix) bug 168412.)
(Reporter)

Comment 1

16 years ago
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4) Gecko/20030529]

In v1.4rc1, Redo (Ctrl-Y) is disabled...
(Now, it's more like bug 53422 was.)

PS: Would it be approriate to add (K) 'dataloss' ?
Summary: In Bookmark Manager, Redo (Ctrl+Y) fails, acting as undelete at least → In Bookmark Manager, Redo (Ctrl+Y) fails, acting as undelete at least. [v1.4rc1: disabled feature !]
(Reporter)

Comment 2

16 years ago
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.3.1) Gecko/20030425]

In v1.3.1, there was no 'Redo (Ctrl-Y)' option: no (K) regression.
(Is this feature new in v1.4* ?)

Comment 3

14 years ago
Seems to be working fine in Linux
(Reporter)

Comment 4

14 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a4) Gecko/20040927] (release) (W98SE)

"WorksForMe" now:
Notice that undeleting is "Undo (Ctrl-Z)" now(!?);
And "Redo (Ctrl+Y)" can delete the item again :-)

Too much time has past for me to remember more details.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 5

14 years ago
I've just tried it now in Thunderbirrd 0.9 (20041103) in WinXP and it still
doesn't work.
I would suggest you to reopen it.
Product: Browser → Seamonkey

Comment 6

14 years ago
It's still not working for me with Firefox 1.00 in Windows XP. Should I create a
new bug ?

Comment 7

14 years ago
I request reopen.

Comment 8

14 years ago
the_redburn@perso.be: ff1.0 is *older* than mozilla1.8a4, try something *newer*
than 1.8a4 and see if the problem persists. note that this bug is filed against
the mozilla application suite, not firefox. so even if this does occur in
firefox-trunk, this bug should only be reopened if it occurs today in mozilla-trunk.

Comment 9

14 years ago
Actually, I confused the Bookmark Manager with the bookmark sidebar.
But the problem with this sidebar is that we cannot undo when we delete a
bookmark. And this sidebar is used more often than the Bookmark Manager.
You need to log in before you can comment on or make changes to this bug.