browser hangs on webpage; cpu usage of mozilla very high

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Detlef Grittner, Assigned: asa)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

This problem occured with several Mozilla builds (mozilla 1.0.1 (SuSE build),
mozilla 1.3 and mozilla 1.4a).
This problem affects only the Linux version, the Windows version (I tested
mozilla 1.3 on W2k) is not affected.
I'm using SuSE 8.1 with kernel 2.4.19.

Reproducible: Sometimes

Steps to Reproduce:
1. go to "Schnellsuche" (quick search) on the page
2. e.g. choose "Geschlecht" (sex) female (second checkbox); Alter (age) from 18
to  33; PLZ (postal code): 91 (or 9)
3. then press "Go!" and use the button "Weiter" (next) several times

Actual Results:  
After some pages the browser hangs and has a high cpu time consumption.
I can't tell, when exactly this will happen, but it seems it depends on the
contents of the webpage.
When the problem occurs, I must use "kill -9 mozilla-bin" to end mozilla.

Expected Results:  
Mozilla should show the contents of the page immediately.

Comment 1

15 years ago
worksforme with linux trunk 20030406
Keywords: hang
(Reporter)

Comment 2

15 years ago
I've just tried mozilla nightly build 2003040708 and it still doesn't work.
I've used 91 as postal code and mozilla hangs when I try to view the second page
of the search results with "Weiter" (next).

Any ideas how I can further investigate the problem?
(Reporter)

Comment 3

15 years ago
Mozilla works again for me. I've created a new profile as workaround.
But I don't now what's the problem with the old profile and how such a profile
makes mozilla hang on the webpage.

I think it's not really a critical problem, though.
Severity: critical → normal

Comment 4

15 years ago
hangs are critical because (among other things) they result in complete loss of
your browsing/mail session.

to further diagnose the problem (assuming you still have the old profile), you can:

1. migrate your prefs to the new profile (see 
   ~/.mozilla/profile/xxx.slt/prefs.js) until Mozilla hangs

2a. *backup your old profile*
 b. remove parts of your old profile (delete cookies.txt, downloads.rdf, 
    history.*, localstore.rdf,  panels.rdf and XUL.mfasl from your profile 
    directory).
 c. remove individual prefs from your prefs.js file
repeat until you discover what part of your profile was related to the hang.
#2 is more effective, but can be destructive, so be sure to backup your profile.
Product: Browser → Seamonkey

Comment 5

13 years ago
Each time I surf this page
(http://www.allocine.fr/seance/salle_gen_csalle=P0047.html) , my CPU rises as
high  as 97% usage when I am scrolling up or down.

I use Firefox version 1.0 (not the latest nightly build, sorry guys !) on
Windows 2K.

Comment 6

13 years ago
Detlef: have you seen this problem recently?

Manf: please file a new bug
(Reporter)

Comment 7

13 years ago
I've had a quick glance at the page with Firefox 1.0.2 on a SuSE 9.2 x86_64
system and couldn't see any problems.
But there seems to be a flash plugin on the page and I don't and can't use flash
with my 64 bit Version of Firefox.

Comment 8

13 years ago
ok, resolving WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.