bookmarks and links fail to load if Mozilla is not already open

RESOLVED DUPLICATE of bug 192849

Status

SeaMonkey
Bookmarks & History
RESOLVED DUPLICATE of bug 192849
15 years ago
14 years ago

People

(Reporter: Robert Warner, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4a) Gecko/20030401

When links are opened from another application they do not load correctly unless
Mozilla is already running before the link is opened. Instead, Mozilla will
launch and display the home page.

Reproducible: Always

Steps to Reproduce:
1. Quit Mozilla
2. Make sure Mozilla is set as the default browser
3. Open a link from another application (ex. "Get MacOSX software" under the
apple menu, a saved bookmark file, AOL instant messenger news ticker).
Actual Results:  
Mozilla will launch properly, but will display the home page instead of the
requested page.

Expected Results:  
Mozilla should load the url associated with the link.
(Reporter)

Comment 1

15 years ago
Also, I seem to recall this bug started with 1.3b, indicating it is probably yet
another Mach-O related problem.

Comment 2

15 years ago
this is a dupe of bug 192849 - [Mach-O] Mozilla, on receiving URL from another
application while shut down, launches and displays blank page rather than URL

*** This bug has been marked as a duplicate of 192849 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.