Stylesheet `width' settings aren't used when rendering TD.

VERIFIED DUPLICATE of bug 19961

Status

()

Core
Layout: Tables
P3
normal
VERIFIED DUPLICATE of bug 19961
18 years ago
18 years ago

People

(Reporter: jonpryor, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I first observed this at the listed URL, but the following code
demonstrates the bug:

<html>
 <head>
  <title>Testing CSS1</title>
  <style>
   .baz { width: 2cm; }
  </style>
 </head>
 <body>
  <table width="100%">
   <tr>
    <td>foo</td>
    <td class="baz">this text should only be two centimeters wide!</td>
    <td>baz</td>
   </tr>
  </table>
 </body>
</html>

To summarize:
 1) We have a table specified to have a width of "100%" -- so
    the table should fill the screen.

 2) One of the subelements of the table -- a TD -- has its width
    specified by a stylesheet (the 2nd TD -- ``<td class="baz">...</td>'').

 3) When rendering this page, the TD with its width specified
    doesn't use the specified width; it uses the "default" width
    (the width that would be used if no `width' setting were present).

It's interesting to note that this isn't limited to just stylesheets;
replacing ``<td class="baz">'' with ``<td width="2cm">'' produces the
exact same effects: the width specified is ignored.

For reference, observe the page in Internet Explorer 5.0 (perhaps
lower), which appears to render the width specifications correctly.

I was unable to test this bug under any other platforms.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M15
(Assignee)

Comment 1

18 years ago
I tried a few different cell widths and noticed that the page is rendered like
Nav4.6. We need a better rendering in "Standard Mode".

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
*** This bug has been marked as a duplicate of 19961 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 3

18 years ago
Verified dup of #19961
You need to log in before you can comment on or make changes to this bug.