If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dragging a bookmark item to the last bookmark folder causes the application to hang

VERIFIED FIXED in mozilla1.4beta

Status

SeaMonkey
Bookmarks & History
P3
critical
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Chris Petersen, Assigned: janv)

Tracking

({hang, regression})

Trunk
mozilla1.4beta
hang, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

Attachments

(1 attachment)

816 bytes, patch
Brian Ryner (not reading)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
Build: 2003-04-07-03 Mach0 trunk and 2003-04-06-04 Win32 trunk
Platform: All
Expected Results: Item that is being dragged should be placed into folder 
What I got: Application hangs

Steps to reproduce:

1) Select Manage Bookmarks from Bookmarks menu
2) Select a folder, bookmark item, or separator
3) Drag and drop this item into the last folder displayed in bookmark window.
4) Application "hangs"
(Reporter)

Updated

15 years ago
Keywords: hang, nsbeta1, regression
(Reporter)

Comment 1

15 years ago
Reassigning
Assignee: ben → varga
(Assignee)

Comment 2

15 years ago
Confirming, I can reproduce it too.

Priority: -- → P3
Target Milestone: --- → mozilla1.4beta

Comment 3

15 years ago
Isn't it a dupe of bug 200878?

Comment 4

15 years ago
It also fails for me (2003040708).

However, it ONLY fails if the last folder is closed.  If it is expanded so that
all of the other bookmarks within that folder are visible, it works.

Comment 5

15 years ago
Per nav triage: nsbeta1+/adt1
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]
(Assignee)

Comment 6

15 years ago
Okey, I know what's happening, patch on the way.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

15 years ago
Created attachment 121117 [details] [diff] [review]
patch

mDropRow can be invalid after calling mView->Drop() because Drop() can affect
row indeces (remove a row above the drop row in this case).
(Assignee)

Updated

15 years ago
Attachment #121117 - Flags: superreview?(jaggernaut)
Attachment #121117 - Flags: review?(bryner)
(Assignee)

Comment 8

15 years ago
*** Bug 200878 has been marked as a duplicate of this bug. ***
Attachment #121117 - Flags: review?(bryner) → review+
(Assignee)

Updated

15 years ago
Attachment #121117 - Flags: superreview?(jaggernaut)
(Assignee)

Comment 9

15 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

15 years ago
Verified in the 2003-04-22-08 Macho and Win32 trunk builds.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

15 years ago
*** Bug 202950 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.