View-Source should be implemented as a tab in the Page Info dialog

VERIFIED WONTFIX

Status

()

Firefox
General
--
enhancement
VERIFIED WONTFIX
15 years ago
14 years ago

People

(Reporter: Rich Doughty, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

This would make the context menus smaller and seems to make sense (to me anyway).

It may also allow for more UI stuff to launch external programs, reformat,
highlight etc.

Just a thought.

Reproducible: Always

Steps to Reproduce:
1.Right click
2.Choose "View Page Info"
3.No "Source" tab...

Comment 1

15 years ago
A source tab would imply a much bigger Page Info window. Since no other tab
would use this space, it'd look weird.
Allowing an external source viewer is bug 172817.

Suggesting WONTFIX.

Comment 2

15 years ago
The full page source has no place in the Page Info dialog. Therefore, this bug
in its current state is WONTFIX. However, I would have no problem with a View
Source button in the Page Info dialog.

Comment 3

15 years ago
Reporter, please respond to this. Can this bug report be changed to a request of
adding a View Source button in the Page Info dialog, or do you still want the
tabbed interface?

(Both alternatives may be WONTFIX'ed.)
(Reporter)

Comment 4

15 years ago
It just struck me that view-source might "belong" in page info. It was something
that came to mind whilst using the LiveHTTPHeaders extension that installs
itself into the page info dialog.

Feel free to WONTFIX. I expect that you have bigger fish to fry at the moment
anyway :-)

Comment 5

15 years ago
These extra features should be implemented by extension.
-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 6

15 years ago
http://mozilla.org/projects/ui/communicator/framework/contextmenus/index.html#Anchor-28258

says make a button on Page Info>General for Page Source

Comment 7

15 years ago
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED

Comment 8

14 years ago
*** Bug 262103 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.