CSS "background-position" attribute - background image with horizontal and vertical positions visualisation problem

RESOLVED DUPLICATE of bug 201126

Status

()

Core
CSS Parsing and Computation
RESOLVED DUPLICATE of bug 201126
16 years ago
16 years ago

People

(Reporter: Rustam Babadjanov, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When trying to set CSS background-position attribute with both horizontal and
vertical positions (indicated in percents or pixels) for specified background
image - Mozilla shows nothing, but in MSIE 5/6 all works fine.

Reproducible: Always

Steps to Reproduce:




<HTML>
<HEAD>
<STYLE>
  .Class1 {
    position: absolute;
    top: 10px; 
    left: 10px; 
    width: 700px; 
    height: 300px;
    padding: 5px;
    border: 1px solid gray;
    z-index: 1;
    /* background */
    background: silver url("http://www.mozilla.org/images/mozilla-banner.gif")
fixed no-repeat 95% center;
  }

  .Class2 {
    position: absolute;
    top: 250px; 
    left: 250px; 
    width: 700px; 
    height: 300px;
    border: 1px solid black;
    padding: 5px;
    z-index : 2;
    /* background */
    background-color: gray;
    background-image: url("http://www.mozilla.org/images/mozilla-banner.gif");
    background-attachment: fixed;
    background-repeat: no-repeat;
    background-position: 12px 60px;
  }
</STYLE>
</HEAD>
<BODY>
 <DIV class="Class1">
   Mozilla CSS background-position bug test 1
 </DIV>
 <DIV class="Class2">
   Mozilla CSS background-position bug test 2
 </DIV>
</BODY>
</HTML>

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 201126 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.