Closed Bug 201153 Opened 21 years ago Closed 12 years ago

Entering a comma in the TO field splits names in addresbook

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: bart.schelstraete, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030407
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030407

The addressbook can't work well with ',' in the names.

Reproducible: Always

Steps to Reproduce:
1.Open a new mail.
2.Enter in the to field, for example:  "YOUR LASTNAME, Firstname" address@domain.com
3.Click the 'address' icon

Actual Results:  
In the Adress message to there a 2 entries, instead of 1:

To: "\"YOUR LASTNAME
To: Firstname\"address@domain.com

Expected Results:  
It should be: "YOUR LASTNAME, Firstname" address@domain.com

I think this is a really important buggie, because a lot of companies are using
email address like that. I know....... a comma in the name isn't really good,
but like I said.......;a lot of them are using it..
Changed OS to 'All', because this problem exists on all OS'ses.
(very important bug for companies)
OS: Linux → All
Hardware: PC → All
mass re-assign.
Assignee: racham → sspitzer
Nobody looking at this???
Probably a related problem:
Open address book;
Add an email address with a comma in its display-name to a list;
Close this list;
Open the list by double clicking on it;
Close it again by pressing 'OK'.
Now the address cut; only the first half of the display-name remains.
Flags: blocking1.6+
Nothing may block a past release. May it?
Flags: blocking1.6+
Sorry. My fault. 1.6 isn't yet a past release :-(
Flags: blocking1.6+
Proposed solution:
Don't split up in this case, just take the whole line, even when the comma *is*
used as a seperator of multiple addresses.
wim.huls@hccnet.nl, please don't set flags if you don't know how. Thanks. 
Flags: blocking1.6+
Still in 1.8a3. If I add as To: "LASTNAME, Firstname" address@domain.com and
then select address I see this in the Select Adresses dialog: 
To: \\LASTNAME, Firstname" address""@domain.com
After ok I see these two lines as To: in the message compose window: 
To: \LASTNAME
To: Firstname" address""@domain.com"

As a workaround use <> for the address: "LASTNAME, Firstname"
<address@domain.com>. After address and ok the To: is not changed. Surprising!

I guess this is related to Bug 254519. Perhaps this isn't AB but a dupe?
Product: Browser → Seamonkey
see similiar bug 188980
Assignee: sspitzer → mail
QA Contact: nbaca → addressbook
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
I still have a problem that seems to be linked to this one. I very often get mails from people that have a comma in their sender ID. Whenever I click on REPLY I'll get 2 lines in the TO section: one usually being just the last name of the addressee (usually not valid) and the second with his or her first name usually followed by the mail address (hence valid). So I think that this bug is still valid and needs to be fixed. Maybe a setting can be introduced that would change the separator from comma to semicolon?
Is this the same as bug 254519 ? Have you tried Thunderbird 3.0 Beta 2?
Click in the 'address' icon woks OK, but:

When I send e-mail with 

"YOUR LASTNAME, Firstname" address@domain.com 

in my Sent folder is e-mail for 

""YOUR LASTNAME, \Firstname" address"""""@domain.com

And in e-mail "failure notice"

<YOURLASTNAME@smtp.domain.com>:
Sorry, no mailbox here by that name. (#5.1.1)

<Firstnameaddress@domain.com>:
Sorry, no mailbox here by that name. (#5.1.1)

Confirm for:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090626 Shredder/3.0b3pre
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090626 SeaMonkey/2.0b1pre
I'm really not sure whether
"LASTNAME, Firstname" address@domain.com
should be treated as a valid input. If you use
"LASTNAME, Firstname" <address@domain.com>
it works (STR from comment 0), so I don't see this as a big issue. However, if it is, the bug should be confirmed.
Whiteboard: [CLOSEME INVA/WONT?]
(In reply to comment #16)
> I'm really not sure whether
> "LASTNAME, Firstname" address@domain.com
> should be treated as a valid input. If you use
> "LASTNAME, Firstname" <address@domain.com>
> it works (STR from comment 0), so I don't see this as a big issue. However, if
> it is, the bug should be confirmed.

For me it's not so much the problem of entering an address in my addressbook, it's more about the others out there who are sending their contact details in the wrong format. So for me it's still a bug that needs to be fixed.
Original problem with address book are no longer present, mail address in form "xxxx" yyyy@domain.com is invalid, checked with TheBat! and provider's mail server, it refuses to send message with such recipient address and returns Incorrect Address Format error.
Question about wrapping address with <> if replying to message with faulty headers may be still valid RFE, but fill separate bug for it. Closing this per whiteboard.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → INVALID
Whiteboard: [CLOSEME INVA/WONT?]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: