[SUGGESTION] Font size in Channels submenu in Bookmarks menu too small

VERIFIED FIXED in M15

Status

SeaMonkey
Bookmarks & History
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Nick Meara, Assigned: Steve Lamm)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Steps to reproduce

1) Start Mozilla
2) Click on "Bookmarks" in the Personal Toolbar (you may have to do this several
times to get the menu to appear)
3) Select the Personal Toolbar Folder item. On the Personal Toolbar submenu the
text for the Channels item is a size smaller that the rest of the text.
4) Select the Channels item. All of the text in the Channels submenu is also a
size smaller than the rest of the Bookmarks menu items. Both are hard to read.

Build date and platform

I noticed this on the M11 build and the 1999112508 builds for both Mac and
Windows.

Additional Information

I suspect that it has to do with the following style declarations in
navigator.css

titledbutton.bookmarkbutton {
   margin: 0px;
   max-width: 8em;
   font: inherit;
   font-size: smaller;
   color: #99CCCC;
   border: none;
   padding: 1px;
   background-image: none;
}

toolbar#PersonalToolbar menu {
  font-size: smaller;
  color: #99CCCC;
}

The relative setting smaller appears to be applied twice to the Channels menu
item and the Channels submenu.

Suggestion

Setting the font-size for both of these to 10px solves the problem temporarily,
but I haven't explored any knock-on effects that this might have in the rest of
the Chrome.
(Reporter)

Comment 1

18 years ago
Created attachment 3148 [details]
Screenshot of Channels submenu

Comment 2

18 years ago
reassign it to browser-general component. cc german to be aware of font size
issue.

Comment 3

18 years ago
reassign it to browser-general component. cc german to be aware of font size
issue.

Updated

18 years ago
Assignee: leger → slamm
Component: Browser-General → Bookmarks

Comment 4

18 years ago
Updating QA contact/component to try reproduction.

Comment 5

18 years ago
*** Bug 23640 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Severity: minor → normal
OS: Mac System 8.6 → All
Hardware: Macintosh → All

Comment 6

18 years ago
this is an XP bug. The screenshot from the dupe shows these to be basically
unreadable on Win32. This is still the case with current(20000112) builds.
(Assignee)

Updated

18 years ago
Target Milestone: M15
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 7

18 years ago
*** Bug 24136 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
notice that per bug 24136 "Bookmark menu tree has smaller font size for each folder sublevel"

Comment 9

18 years ago
wasn't this fixed? Maybe there was a dupe I didn't catch and it was 'fixed' ?
On the PToolbar, I can select Bookmarks|Personal Toolbar Folder|Test Folder|test link and each sublevel uses the same, easily 
readable fontsize.
(Reporter)

Comment 10

18 years ago
Claudius, I agree with you and can verify that this was fixed in M13 on the Mac 
and isn't showing in the 2000031516 build on Win NT 4. I'm not sure if I can mark 
it as such, however, or if someone from QA has to verify it.

Comment 11

18 years ago
marking fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
and verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.