Editor Commands should accept UTF8 strings in state_ attribute

VERIFIED FIXED in mozilla1.4beta

Status

()

VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: carosendahl, Assigned: Brade)

Tracking

({intl, topembed+})

Trunk
mozilla1.4beta
intl, topembed+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: edt_x3 editorbase+)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

16 years ago
Various commands need to accept UTF8 strings in addition to/instead of ASCII
strings.

In particular, cmd_fontFace.  

The others (align, color, bgcolor, etc.) appear to get by with a char string.
(Reporter)

Updated

16 years ago
QA Contact: sairuh → carosendahl
Whiteboard: edt_x3 topembed editorbase
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Keywords: topembed
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: edt_x3 topembed editorbase → edt_x3 editorbase

Comment 1

16 years ago
topembed triage: plussing, required by international product localizations of
Gecko embedding customers.
Keywords: topembed → topembed+

Comment 2

16 years ago
Created attachment 120677 [details] [diff] [review]
proposed fix - use nsString instead of nsCString

Comment 3

16 years ago
add myself to cc
(Assignee)

Comment 4

16 years ago
Comment on attachment 120677 [details] [diff] [review]
proposed fix - use nsString instead of nsCString

Taka--r=brade for branch (assuming you have tested it with satisfactory
results)

I think the trunk will require a different (but nearly identical patch) and
testing with jag's work.
Attachment #120677 - Flags: review+

Comment 5

16 years ago
Checking in nsComposerCommands.cpp;
/cvsroot/mozilla/editor/composer/src/nsComposerCommands.cpp,v  <--  nsComposerCo
mmands.cpp
new revision: 1.58.6.4; previous revision: 1.58.6.3
done

checked into branch.
(Assignee)

Comment 6

16 years ago
Created attachment 120764 [details] [diff] [review]
taka's patch ported to trunk
Attachment #120677 - Attachment is obsolete: true
(Assignee)

Comment 7

16 years ago
Comment on attachment 120764 [details] [diff] [review]
taka's patch ported to trunk

carryforward my r=
jag--can you please test with your changes and sr=?  I can't test font menu in
my debug build on macho (I get JS warnings/errors on console).
Attachment #120764 - Flags: superreview?(jaggernaut)
Attachment #120764 - Flags: review+
editorbase+
Whiteboard: edt_x3 editorbase → edt_x3 editorbase+

Comment 9

16 years ago
Comment on attachment 120764 [details] [diff] [review]
taka's patch ported to trunk

sr=jag
Attachment #120764 - Flags: superreview?(jaggernaut) → superreview+

Updated

16 years ago
Keywords: intl
(Assignee)

Comment 10

16 years ago
I believe this is already addressed where appropriate.  If there are specific
cases, we should file them as separate bugs.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.4beta
(Reporter)

Comment 11

16 years ago
Verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.