Password manager crashes when resized to be large

RESOLVED WORKSFORME

Status

SeaMonkey
Passwords & Permissions
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Robert Goldman, Assigned: dveditz)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

I can reliably crash Mozilla's password manager by resizing it to be large. 
This crash takes down all of Mozilla in the process

Reproducible: Always

Steps to Reproduce:
1. Tools -> Password Manager
2. Grab lower right corner of password manager window and pull it down and to
the right.  This can be done to a limited extent, but beyond a certain point
(and well within my screen dimensions), it will cause Mozilla to crash.


Actual Results:  
Mozilla crashes.  When I invoked mozilla from a shell, I saw the following error
message:
/home/rpg/bin/mozilla-1.4a/mozilla/run-mozilla.sh: line 72: 21208 Segmentation
fault      "$prog" ${1+"$@"}

Expected Results:  
Resized window.

/home/rpg/bin/mozilla-1.4a/mozilla/run-mozilla.sh: line 72: 21208 Segmentation
fault      "$prog" ${1+"$@"}

Comment 1

16 years ago
worksforme with linux turnk 20030409.  I resized it well beyond my screen
dimensions (1280x1024) without crashing.

are you using a talkback enabled build? (or perhaps an RPM build?)
can you try a clean profile (it might somehow be related to the passwords you
have stored)?
Keywords: crash
(Reporter)

Comment 2

16 years ago
Since this is my password manager, I'm reluctant to use a talkback build.  I
don't have any way of determining what informaiton will be delivered as part of
that. 

I just created a new profile.  Stretched the Password Manager window.  Crashed
again.   Same command line message:
/home/rpg/bin/mozilla-1.4a/mozilla/run-mozilla.sh: line 72:  3664 Segmentation fault
  "$prog" ${1+"$@"}

I will try to take a little time soon and install a talkback build.  Presumably
I can fire that up with my empty profile and replicate the bug.

I have been able to replicate this both with mozilla 1.3.1 and 1.4a without any
trouble.
(Reporter)

Comment 3

16 years ago
I'm afraid I'm not sure how to do this properly, but I have reproduced the bug
with a talkback build, and filed Talkback incident TB19025606Q.  If this
information belongs somewhere else (e.g. attachment), sorry!

Comment 4

16 years ago
thanks Robert!
Keywords: stackwanted
Whiteboard: TB19025606Q

Comment 5

15 years ago
if still crashing with 1.4 or 1.5a, please post a new Talkback ID as previous
ones have probably expired.

Comment 6

15 years ago
Using Moz 1.7Beta, I was unable to reproduce this crash. While I resized, I did
get some nasty redraw (not very many windows open, only Chatzilla and Firefox in
addition to Moz) but no crash at all.

Reporter, are you still seeing this with a recent build and a clean profile? If
not could you please Resolve as WORKSFORME?

Updated

14 years ago
Whiteboard: TB19025606Q

Comment 7

14 years ago
No action in this bug in quite sometime, and still no crash with Moz 1.7 RC1:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040421 on Slackware
Current.

Please close this bug as WORKSFORME

Comment 8

14 years ago
Marking WFM, please reopen if still crashing using 1.7RC or later builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.