Userlist not always kept sorted as requested

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: dbachran-bz, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

After implementation of bug 199067 the userlist is not always kept sorted
correctly: When clicking on the column labeled "Nick", the userlist is being
sorted correctly, but whenever a nick is being changed the list is not updated
to reflect the requested sort-order.

Reproducible: Always

Steps to Reproduce:
1. join a channel with some users logged in, e.g. using nick 'aaa'
2. sort the userlist by clicking on the column 'Nick' until it is being sorted
(either one of the two triangles is being shown in the column right corner)
2. change your nick to 'zzz'

Actual Results:  
- the nick is being changed to 'zzz'
- the position of the nick 'zzz' in the userlist is the same as the one of the
previous nick 'aaa' and doesn't reflect the requested sort-order anymore


Expected Results:  
- cz updates the position of the nick 'zzz' in the userlist so that the list is
kept sorted as requested


I have additionally had the impression that users joining/leaving the channel
might cause an unsorted userlist, but I can't reproduce that right now. Might
have only occured right at the beginning as I started ChatZilla.
(Reporter)

Comment 1

16 years ago
When starting CZ, the triangle in the 'Nick' column is being shown as selected
the last time (i.e. the sort order was stored and this indicates that it should
still be the same as in the last session) but the userlist is not sorted!

After clicking on the 'Nick' column the userlist is being sorted correctly, though.

My other comment with the userlist order not being updated whenever the nick
changes is also still valid.

This is with CZ 0.8.26.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Depends on: 199067
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

16 years ago
Created attachment 120510 [details] [diff] [review]
patch v1

onJoin() and onNick() should call the sorting function.

Updated

16 years ago
Attachment #120510 - Flags: review?(rginda)
(Assignee)

Comment 3

16 years ago
Comment on attachment 120510 [details] [diff] [review]
patch v1

will be included in latest xpi
Attachment #120510 - Flags: review?(rginda) → review+
(Assignee)

Comment 4

16 years ago
marking fixed, 0.8.34 checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Core → Other Applications
You need to log in before you can comment on or make changes to this bug.