TLS intolerance detection broken

RESOLVED FIXED in mozilla1.4beta

Status

()

P1
critical
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: kaie, Assigned: darin.moz)

Tracking

({topembed})

Trunk
mozilla1.4beta
topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
edit/prefs/privacy/ssl:
  make sure SSL2, SSL3, TLS are all enabled

Go to
  https://webmail.wittenberg.edu

With Mozilla 1.2: 
  works
  (You can watch the statusbar to see that Mozilla
   tries to connect twice, caused by the TLS intolerance detection)

With Mozilla 1.3 or recent trunk: 
  error message "Document contains no data"

Expected behaviour:
  The connection should succeed


The connection works after one disables TLS, forcing PSM not to use TLS.
(Assignee)

Comment 1

16 years ago
my bug.  i busted this.
Assignee: ssaux → darin
Component: Client Library → Networking: HTTP
Product: PSM → Browser
QA Contact: bmartin → httpqa
Target Milestone: --- → mozilla1.4beta
Version: unspecified → Trunk
(Assignee)

Updated

16 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Flags: blocking1.4b?
Keywords: nsbeta1, topembed
Priority: -- → P1
(Assignee)

Comment 2

16 years ago
Created attachment 120053 [details] [diff] [review]
v1 patch
(Assignee)

Updated

16 years ago
Attachment #120053 - Flags: review?(kaie)
(Reporter)

Comment 3

16 years ago
Comment on attachment 120053 [details] [diff] [review]
v1 patch

Thanks for the patch! I tested it, it works for me.

r=kaie
Attachment #120053 - Flags: review?(kaie) → review+
(Assignee)

Updated

16 years ago
Attachment #120053 - Flags: superreview?(alecf)

Comment 4

16 years ago
Comment on attachment 120053 [details] [diff] [review]
v1 patch

sr=alecf
Attachment #120053 - Flags: superreview?(alecf) → superreview+
(Assignee)

Comment 5

16 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Flags: blocking1.4b?
You need to log in before you can comment on or make changes to this bug.