Browser functionality diminished when any "Save" dialog open

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
16 years ago
5 years ago

People

(Reporter: goi, Assigned: jag+mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030409 Phoenix/0.5+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030409 Phoenix/0.5+

When any "Save" dialog is open, including "Save Image As", "Save Link As" and
"Save Page As", the browser functionality seems to be reduced. I can no longer
use the mousewheel to scroll, nor open a new browser window, nor open a new link
even.

I'm not sure if any other functionality is broken when these dialogs are open,
but these are the ones I've found so far.

Reproducible: Always

Steps to Reproduce:
1. Open 2 browser Windows and load 2 websites on them
2. In the first window, right click and choose "Save Page As"
3. Try to use your mousewheel on the 2nd window, or go to a new link, or open a
new window

Actual Results:  
Nothing will happen until the "Save" dialog on the first window is closed

Expected Results:  
mousewheel should still work, I should still be able to browse to new links on
another window, and I should still be able to open a new window.
(Reporter)

Comment 1

16 years ago
I forgot to mention, this happens on both 0408 and 0409 builds, I'm not sure of
the older builds, but its likely as well. However, it doesn't happen on Mozilla
0408 build nor Mozilla 1.3 final, so it could be a Phoenix specific bug, or
somehow it isn't showing up on Mozilla.
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030409
Phoenix/0.5+
Confirming using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a)
Gecko/20030408 Phoenix/0.5+
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
I managed to reproduce some parts of comment #1. When a Save Image as dialog has
been opened by Window1, here's what I see in Window2
- No possibility to load a page in a new tab (actually, the tab is opened, but
it doesn't load any page)
- No possibility to open a new window (in fact, the new window(s) will open as
soon as the Save dialog is closed, so the command is stored somewhere), but
isn't it because the Save dialog is modal?
- No scrolling *only if general.smoothScroll is set to true*. Normal scrolling
works perfectly (which is why I originally thought it was WFM).

And I'm also seeing this in Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.4b) Gecko/20030408

-> Browser
Assignee: blaker → asa
Component: General → Browser-General
Product: Phoenix → Browser
Whiteboard: dupeme
Version: unspecified → Trunk
(Reporter)

Comment 5

16 years ago
Still happens with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a)
Gecko/20030423 Firebird Browser/0.6

But not assigned yet?

Comment 6

16 years ago
This is most likely a dupe of bug 74331
Mostly can confirm this using Mozilla/5.0 (Windows; U; Windows NT 5.0; es-ES;
rv:1.5) Gecko/20030916

I can still scroll and read from one window while another has a save as dialog
open, but if I, for example, right click on an image, it takes a long time for
the menu to come up. I choose "save image as", and do not get a "save as" dialog
until I have closed the first save dialog.

Comment 8

16 years ago
->XPApps
Assignee: asa → jag
Component: Browser-General → XP Apps
QA Contact: asa → pawyskoczka

Comment 9

16 years ago
This looks like a potential dupe of bug 150006 to me. It seems like if one
Mozilla window has a modal dialog open (like Save As or Print), many things do
not work such as navigating to a new site via the URL bar.

Comment 10

15 years ago
(In reply to comment #9)
> This looks like a potential dupe of bug 150006 to me. It seems like if one
> Mozilla window has a modal dialog open (like Save As or Print), many things do
> not work such as navigating to a new site via the URL bar.

Yes, because the loading of a page is a networking action. So this bug and bug
150006 are dupes of bug 74331. See there.

Comment 11

15 years ago
(In reply to comment #0)
> Steps to Reproduce:
> 1. Open 2 browser Windows and load 2 websites on them
> 2. In the first window, right click and choose "Save Page As"
> 3. Try to use your mousewheel on the 2nd window, or go to a new link, or open a
> new window

Works now with 1.8a5 on WinNT4. For other issues see bug 150006 and bug 74331.

Feel free to reopen if you can reproduce it with current builds.

(In reply to comment #4)
> I managed to reproduce some parts of comment #1. When a Save Image as dialog has
> been opened by Window1, here's what I see in Window2
> - No possibility to load a page in a new tab (actually, the tab is opened, but
> it doesn't load any page)
> - No possibility to open a new window (in fact, the new window(s) will open as
> soon as the Save dialog is closed, so the command is stored somewhere), but
> isn't it because the Save dialog is modal?
> - No scrolling *only if general.smoothScroll is set to true*. Normal scrolling
> works perfectly (which is why I originally thought it was WFM).

WFM too.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → Mozilla Application Suite

Updated

5 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.