CTRL SHIFT R or REPLY ALL will pull address from last message sent and not the current message recipient list

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Barry Treahy, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030409
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030409

This is a problem that has haunted me since early 1 Mozilla beta's when I first
reported it and I've been hoping it would get tackled but it hasn't and Mozilla
doesn't even bring up my original posting :-(  

When using the CTRL-SHIFT-R shortcut for REPLY ALL, the composition window opens
with nothing listed in the To: field and if you enter a value, that value is
ignored and the message is actually send to the 'last To:' used in the most
latest message actually sent!  You can imagine how embarrassing this can become!

Reproducible: Sometimes

Steps to Reproduce:
1. CTRL-SHIFT-R to respond to existing, selected message
2. Key reply message and click send - error occurs because there is no To: address
3. Key address and click send - message is sent to wrong address

Actual Results:  
Message would be sent to the wrong person, which is confirmed in the Sent folder.

Expected Results:  
When the CTRL-SHIFT-R is used, I expect the proper addresses to be loaded and
more importantly, the message delivered to only these people and not people from
prior sent e-mails!
(Reporter)

Comment 1

15 years ago
This is an example of a message header that produces the problem each and every
time:

From - Wed Apr 09 10:21:18 2003
X-UIDL: :UO"!K:o!!GSD!!6H_!!
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Received: from mml2.mmaz.com (mml2.mmaz.com [207.254.14.183])
	by mml2.mmaz.com (8.12.8/8.12.5) with ESMTP id h39HLVC9031542
	for <treahy>; Wed, 9 Apr 2003 10:21:31 -0700
Received: from mars3.wgrd.net (mars.watchguard.com [206.253.208.99])
	by mml2.mmaz.com (8.12.8/8.12.5) with ESMTP id h39HLUSc031538
	for <treahy@mmaz.com>; Wed, 9 Apr 2003 10:21:30 -0700
To: (Recipients of 'ssf+networkconfig' suppressed)
From: "ssf+networkconfig Listmanager" <listmanager@watchguard.com>
Subject: Proxy cacheing
Reply-To: "Network Configuration Questions"
<ssf+networkconfig.28360@forum.watchguard.com>
Message-ID: <084d0bbbe1bb2b3f4a3bdb1168629e253e945646@watchguard.com>
Date: 9 Apr 2003 10:16:06 -0700
X-UIDL: :UO"!K:o!!GSD!!6H_!!

If a REPLY-ALL done on this and then you bounce to another window and what
appears to have a select message open and a message displayed in the pane and do
another REPLY-ALL, it will pull the addresses from that prior message!
(Reporter)

Comment 2

15 years ago
Sorry for the fragmented thoughts - Shutting down all of Mozilla (browser,
clients, etc) is the only way of clearing this until the next occurance...

Comment 3

14 years ago
Barry Treahy, is this bug still an issue for you?  Your report is very hard to 
understand, particularly the end of comment 1.  "Bounce to another window"?

You quoted a message showing:
To: (Recipients of 'ssf+networkconfig' suppressed)

Is that the actual header, or did you do the suppressing?

(Reporter)

Comment 4

14 years ago
Good day.  

I've running Thunderbird M4+, and earlier versions since last fall, and I can't
say that I recall this happening here.

As for restating the original problem, during a REPLY-ALL, no addresses would
appear in the address window and if you did enter any, the message would not be
delivered to them but rather the address(s) of the last person you sent a
message to!

No, I did not alter the SMTP headers either...

Regards,

Barry

Comment 5

14 years ago
=>WFM per reporter's comment 4.

Barry, feel free to reopen this bug if you re-encounter the problem, with 
Mozilla or with TB.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.