If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Always focus the Location Bar of blank windows when brought to foreground

VERIFIED WONTFIX

Status

Camino Graveyard
General
--
enhancement
VERIFIED WONTFIX
15 years ago
12 years ago

People

(Reporter: Ben, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.5
PowerPC
Mac OS X

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.0.1) Gecko/20030306 Camino/0.7

When I switch from another application to an empty window in Camino, the cursor
does not appear in the Location field.

Reproducible: Always

Steps to Reproduce:
1. Position the window focus in the contents portion of an empty window by
clicking there.
2. Click in another window in Camino or in another application
3. Click back in Camino.

Actual Results:  
Focus stays in the content field of the window.

Expected Results:  
Focus should move automatically to the "Location" field of the window.

Comment 1

15 years ago
Why? You explicitly focused the content area. Why should Camino second-guess you?
(Reporter)

Comment 2

15 years ago
If you're switching from another application to an empty Camino window, it's 
because you want to type in a URL and go somewhere, regardless of what you were 
doing in Camino before.

Comment 3

15 years ago
Hmmm... 

It looks like the cursor remains wherever it was when you left it (Camino
2003042505). Considering the following I can't see why this isn't the expected
behavior.

(a) you have to work to get the focus out of the location bar in the first place.
(b) an "empty" window (new window that doesn't load the homepage by default)
behaves the same way that a window with a page loaded in it does.

... am i missing something? has this behavior changed since 0.7?

Comment 4

15 years ago
Is there a good reason why one should be allowed to focus empty content in the
first place?

Updated

15 years ago
Summary: Improvement for focus-changing → Always focus the Location Bar of blank windows when brought to foreground
(Assignee)

Comment 5

14 years ago
hrm, interesting.
Assignee: saari → pinkerton
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Camino1.1

Comment 6

13 years ago
I agree with Manfred. It serves no purpose whatsoever.

Comment 7

12 years ago
I would like to add that, focus always at the location bar when creating a new tab.

The latest nightly release, the location bar is not the focus even though you
created a new tab (cmd-t) with the current tab location bar in focus (cursor
positioned in location bar).

Comment 8

12 years ago
Oh forget about my previous comment, looks like this is quite a different case
from what I described.
Sorry.
This bug is WONTFIX per discussion in IRC.

We keep focus where it was when you left the app. If the focus was in the content area, we keep it there. If it was in the location bar, we keep it there. This is the correct behavior. Focusing blank content was the user's choice and we should honor it when switching back to the blank window.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
QA Contact: winnie → general
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.