Status

()

P3
minor
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: laotzu, Assigned: rickg)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
http://files.moo.ca/pics/xwd.jpg shows a picture of how mozilla (build ID
1999112608) rendered the given url. This was not what the page should look like
(and how it is correctly displayed under netscape 4.7, MSIE, ect.)
(Reporter)

Comment 1

19 years ago
Created attachment 3064 [details]
Screenshot showing incorrect rendering of page

Updated

19 years ago
Assignee: karnaze → rickg
Severity: major → minor
Component: HTMLTables → Parser
OS: Linux → All

Comment 2

19 years ago
The problem is a simple typo in the DOCTYPE, there is a missing " before -//W3C:
<!DOCTYPE HTML PUBLIC -//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC_html40/loose.dtd">

The page looks good when the typo is fixed. Note however that Nav4.08 and IE5
doesn't have a problem with this page. Reassigning to Parser.
(Reporter)

Comment 3

19 years ago
I went and fixed the typo on this page (it is one of my own pages), but the
attached shot still shows what the problem was. I suppose I should be thankful
that it was just a minor error and not as major as it seemed at first. ;)

Updated

19 years ago
QA Contact: chrisd → janc
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
Ok -- I'll loosen up the parsing rules here just a tad.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
Fixed by update to nsHTMLTokens.cpp

Comment 6

18 years ago
updated qa contact.
QA Contact: janc → bsharma

Comment 7

18 years ago
Verified on:
build: 2001-05-21-11-Mtrunk
platform: WinNT

The page renders properly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.