Crash when java attempts to read cookies

RESOLVED FIXED

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED FIXED
15 years ago
7 years ago

People

(Reporter: Justin Larue, Assigned: Joshua Xia)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Bug Flags:
blocking1.4b -
blocking1.4 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030409
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030409

Attempting to load this page, which has a Java applet which loads and stores
cookies, breaks under 1.4a and under the latest daily build; it worked under
1.3final.  Trace from the java console follows as attachment.  I don't know of
any other java-using sites that load/store cookies.


Reproducible: Always

Steps to Reproduce:
1.  Make sure the latest Java plugins are installed
2.  Go to www.popcap.com
3.  Click on the "play now" button for the Insaniquarium game

Actual Results:  
Java loads normally, if it is not already loaded, and then the browser freezes.
 The java console displays those messages, and then mozilla crashes.

Expected Results:  
Played the game properly.
(Reporter)

Comment 1

15 years ago
Created attachment 120052 [details]
Java trace from cookie-reading crash

Comment 2

15 years ago
here's the stack trace i got.  however, the crash didn't occur until i tried to
close the game window.  (it didn't seem to be loading.)

0148391e()
enter_js_from_java_impl(JNIEnv_ * 0x03978b68, char * * 0x0012f618, void * *
0x00000000, int 0, void * 0x21253be0, void * 0x213cf3c0) line 426 + 19 bytes
jsj_enter_js(const JNINativeInterface_ * * 0x03978b68, void * 0x213cf3c0,
_jobject * 0x00000000, JSContext * * 0x0012f668, JSObject * * 0x00000000, void
(JSContext *, const char *, JSErrorReport *)* * 0x0012f660, void * * 0x00000000,
int 0, void * 0x21253be0) line 705 + 33 bytes
nsCLiveconnect::GetWindow(nsCLiveconnect * const 0x2262d328, JNIEnv_ *
0x03978b68, void * 0x213cf3c0, void * * 0x00000000, int 0, nsISupports *
0x21253be0, long * 0x21283074) line 705 + 40 bytes
JPINS32! 6d7a9dce()
JPINS32! 6d7a9bdd()
PL_HandleEvent(PLEvent * 0x2263aa98) line 659 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00dedee0) line 592 + 9 bytes
nsEventQueueImpl::ProcessPendingEvents(nsEventQueueImpl * const 0x00dede50) line
387 + 12 bytes
nsWindow::DispatchPendingEvents() line 3802
nsWindow::ProcessMessage(unsigned int 512, unsigned int 0, long 47842281, long *
0x0012fc30) line 4145
nsWindow::WindowProc(HWND__ * 0x001402ae, unsigned int 512, unsigned int 0, long
47842281) line 1448 + 27 bytes
USER32! 77e13eb0()
USER32! 77e1401a()
USER32! 77e13f0f()
nsAppShellService::Run(nsAppShellService * const 0x0146f820) line 480
main1(int 3, char * * 0x00264360, nsISupports * 0x00defcd8) line 1271 + 32 bytes
main(int 3, char * * 0x00264360) line 1650 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87903()

Comment 3

15 years ago
dwitte says he can repro the exact same crash as i just described using moz 1.3.
 given the stack, i think plugins should take a look at this.  please bounce
back to cookies if indeed this is some kind of cookies bug.

-> plugins
Assignee: darin → peterlubczynski
Status: UNCONFIRMED → NEW
Component: Cookies → Plug-ins
Ever confirmed: true
QA Contact: cookieqa → bmartin

Comment 4

15 years ago
TB19017694G
Wonderful crash when closing the window, first DocWatson came up, then Talkback,
then DocWatson froze, and I clicked 3 times to confirm action of Talkback, then
Talkback froze, and all was frozen. Moving the mouse generated sound from the pc
internal speaker, supposedly each pulse from the mouse was a click on the
PC-Speaker.
I had to do a hard reset, and when I started Mozilla, Talkback came up again,
and I confirmed, so it can do it´s action.


Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030409
Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

This is original Win98, not Win98SE, so I don´t know if I can run Java 1.4.2beta.

Comment 5

15 years ago
--->OJI
Assignee: peterlubczynski → joshua.xia
Component: Plug-ins → OJI
QA Contact: bmartin → dsirnapalli

Comment 6

15 years ago
fwiw, I couldn't get Mozilla 2003041008 to crash on Linux using JRE 1.4.2b19.

Java console shows some content, amongst which one related to cookies:

[...]
OJIPlugin acq Spontaneous pipe=10
Trying to enter spont monitor: 0
 OJIPlugin release for:Thread[thread
applet-fishtank/FishtankApplet.class,4,http://www.popcap.com/games/insaniquarium/-threadGroup]
OJIPlugin releasePipe - exiting spont monitor
Did not find cookie: INSANIQUARIUM
DrawDirtyStuff()
Current thread:Thread[Finalizer,8,system]
OJIPlugin: No AThread
Keywords: crash
(Assignee)

Comment 7

15 years ago
can't reproduce on:

Mozilla 1.4a
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030402
and
jre1.4.1_01

Comment 8

15 years ago
exes overinstalled
TB19061680Q WITH BuildID 2003041009
TB19062027Y with BuildID 2003040209
TB19062202X with BuildID 2003040105
exes installed after deinstallation of previous install:
TB19062715Y with BuildID 2003040105

older installation in another folder:
TB19062890Z
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

another, not related crash from this installation: TB18142927Q

Comment 9

15 years ago
TB19063563G
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030411
Java Plug-in 1.4.1_02 for Netscape Navigator (DLL Helper)

Installed after deinstallation of previous version, and created fresh profile
for test, loaded only bugzilla bug url in 1st tab and test url in 2nd tab.
When loading of testurl was hanging, I activated Stop button.

When I tried to manually enter a URL, it was written RIGHT TO LEFT:

i.e. I was typing www.heise.de, but I was seeing then ed.esieh.www
This URL didn´t load, and when I typed it reverse to get it seen right,
it also didn´t load. (Maybe because I didn´t add http:// myself)
(Assignee)

Comment 10

15 years ago
*** Bug 203372 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
setting blocking1.4b? flag. Joshua, feel free to remove it if you think it's bogus.
Flags: blocking1.4b?
(Assignee)

Comment 12

15 years ago
Xiaobin,

I checked this bug, jre call nsCLiveconnect::GetWindow and pass a invalid
java_applet_object value to browser so that lead to this crash.

Please check it.

Thanks!

Updated

15 years ago
Flags: blocking1.4b?
Flags: blocking1.4b-
Flags: blocking1.4?

Comment 13

15 years ago
We'd like to get a fix for this but we're not going to block 1.4 on it.
Flags: blocking1.4? → blocking1.4-

Comment 14

15 years ago
Joshua,

Using latest build of JRE 1.4.2 can not reproduce the bug.
(Assignee)

Comment 15

15 years ago
fixed on JRE 1.4.2
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.