saved IMAP attachments result in the first 20 - 30 bytes saved, but no more

RESOLVED DUPLICATE of bug 249195

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 249195
15 years ago
9 years ago

People

(Reporter: Graham Leggett, Assigned: Bienvenu)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3) Gecko/20030318
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.3) Gecko/20030318

- Receive an email message with multiple file attachments.

- Using a *slow* (as in dialup speed) line, select the message.

- Mozilla at this point starts downloading "stuff", but does not indicate what
it is downloading, or when it can be expected to be complete.

- Try and save the attachment. The attachment seems to be saved correctly, but
on closer investigation, only a few bytes of what appears like noise are saved.
Usually the file length is less than 30 bytes, and seems to be different in each
case.

- Mozilla offers no option to try and re-download a message, so the only
workaround is to move the message to another folder, and try and download it again.


Reproducible: Sometimes

Steps to Reproduce:
xxx
I have the same thing (1.4, 1.5 under windows xp) especially with .zip
attachments sent via microsoft exchange web interface (outlook web access).

However, the attachment can be unpacked properly using local client (like pine).
(Assignee)

Comment 2

14 years ago
can you try a 1.6 build from today? If that doesn't work, can you attach an imap
protocol log of a failed download by following these instructions? thx.

http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
This happened again with mozilla v1.7.

Steps taken:

- Turn on imap protocol logging via the environment variables
- Start up mozilla mail
- Select message with many attachments that has shown this problem
- Select "save all".
- Out of 13 attachments, 12 have a size of 27 bytes, and just one has a size of
69k - no idea if the 69k attachment is a complete download.

The imap log is attached.
(Reporter)

Comment 4

14 years ago
Created attachment 154459 [details]
imap log file (gzip compressed)

Imap log file referred to in the previous comment, compressed with gzip
(Assignee)

Comment 5

13 years ago
can you try a recent 1.8 trunk build, or a recent 1.7.3 build?  I believe I've
checked in a fix for this.
(Assignee)

Comment 6

13 years ago
I believe the fix in bug 249195 also fixes this problem. Marking dup.

*** This bug has been marked as a duplicate of 249195 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.