text-transform problems

VERIFIED FIXED in M6

Status

()

Core
Layout
P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: dbaron, Assigned: buster)

Tracking

Trunk
Other
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
2 text-transform problems in the above URL: (there is another in bug 1929)

1) There is no capital letter after   under text-transform: capitalize.

2) Accented letters are not text-transformed.  I know I offered to make a
slightly better temporary fix for this, but then I decided it was better to
leave as-is until the real fix... (but if the real one never comes, I can give
you a better version)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 1

19 years ago
*** Bug 1218 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

19 years ago
Note that the soft-hyphen test in
http://www.w3.org/Style/CSS/Test/transform.html was removed from the above URL.
You should also fix that, but it would be even better if you really treated
­ as a discretionary hyphen (perhaps this has changed - I don't have access
to the viewer right now)

Comment 3

19 years ago
Setting all current Open/Normal to M4.

Comment 4

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Comment 5

19 years ago
With current builds this test passes fine; the i18n guys hooked up something so
that now the accented letters are transformed.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

19 years ago
Verified fixed.  Looks great on Latin1, extended Latin, Greek, and Russian (i.e., those of the first 1200 characters that I can see).
You need to log in before you can comment on or make changes to this bug.