lacks the possibility to send files with Content-Disposition set to "attachment" instead of "inline".

VERIFIED DUPLICATE of bug 66915

Status

MailNews Core
Composition
--
enhancement
VERIFIED DUPLICATE of bug 66915
15 years ago
10 years ago

People

(Reporter: Stephane Jakob, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

When I compose a message and add some files as attachments those files have 
their "Content-Disposition" set to "inline" instead of "attachment".

The effect is that images are automatically displayed by the recipient.
If it was "attachment", the recipient should click on the icon representing
the file (= what is done for example when the file is a .zip or any non-image
format).

It would be nice to have the choice, for example in Options->Format, to have
the disposition "inline" or "attachment"

Reproducible: Always

Steps to Reproduce:
1. Compose new mail
2. Attach files (pictures)
3. Send
4. Receive

Actual Results:  
Return-Path: <sjakob@free.fr>
Delivered-To: online.fr-sjakob@free.fr
Received: (qmail 5995 invoked from network); 10 Apr 2003 21:54:38 -0000
Received: from postfix4-1.free.fr (213.228.0.62)
  by mrelay4-2.free.fr with SMTP; 10 Apr 2003 21:54:38 -0000
Received: from free.fr (unknown [213.228.24.239])
	by postfix4-1.free.fr (Postfix) with ESMTP id 74A0B19E3D
	for <sjakob@free.fr>; Thu, 10 Apr 2003 23:53:20 +0200 (CEST)
Message-ID: <3E95E7CE.2080801@free.fr>
Date: Thu, 10 Apr 2003 23:53:18 +0200
From: Stephane JAKOB <sjakob@free.fr>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
X-Accept-Language: fr-fr, en-us, en
MIME-Version: 1.0
To: sjakob@free.fr
Subject: test with 1 picture and an archive : dispostion : attachment or inline
 ?
Content-Type: multipart/mixed;
 boundary="------------000204040005050205030006"

This is a multi-part message in MIME format.
--------------000204040005050205030006
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

dispostion : attachment or inline ?

--------------000204040005050205030006
Content-Type: image/png;
 name="votre_avis_DGI.png"
Content-Transfer-Encoding: base64
Content-Disposition: inline;    <------------------- HERE
 filename="votre_avis_DGI.png"

iVBORw0KGgoAAAANSUhEUgAAAhYAAAF4CAIAAACHMyczAAAgAElEQVR4nO3de3Acx33g8YaL
[...]
3ywAAAAASUVORK5CYII=
--------------000204040005050205030006
Content-Type: application/x-gzip;
 name="dnetc-linux-x86-elf.tar.gz"
Content-Transfer-Encoding: base64
Content-Disposition: inline;            <------------------- HERE
 filename="dnetc-linux-x86-elf.tar.gz"

H4sIAC/0Qj4CA+y9C3hU1dUwfM7cMoSECRAgYIBBRkgkYCIRMiSRkBuoASd31KCoqEOkVuEc
[...]
J37+FyjRScgA0BEA
--------------000204040005050205030006--

Expected Results:  
--------------000204040005050205030006
Content-Type: image/png;
 name="votre_avis_DGI.png"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;  <------------------- HERE
 filename="votre_avis_DGI.png"

iVBORw0KGgoAAAANSUhEUgAAAhYAAAF4CAIAAACHMyczAAAgAElEQVR4nO3de3Acx33g8YaL

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 66915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.