CSS commands which work in IE 5.5 don't work in Mozilla, height=percentage in HTML doesn't work

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
16 years ago
16 years ago

People

(Reporter: david, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3) Gecko/20030312

I designed this page using IE as the reference.  Anyway, in the table, it uses
height=97% to fill the whole window (stupid Geocities makes it scroll because of
their dodgy ad code).  In Mozilla, it only recognises fixed pixel amounts in the
table height tag (ie. height=50).

Mozilla doesn't recognise the CSS tags I use for the scrollbar colour code,
background colour code or body text colour code - these all work fine in IE.

The background colour of the page should be a dark grey (#222222), and the text
colour should be a near-white grey colour (#CCCCCC).  I suppose the best way to
compare is to use IE to view the websites.  I have also moved the website to
www.changeofpace.live.com.au where I have made a couple of modifications (since
the border looks really stupid in Mozilla with it's beveled appearance...
doesn't suit the page)

Reproducible: Always

Steps to Reproduce:
1. Visit the website, heh...
Actual Results:  
See details

Expected Results:  
See Details
The body background doesn't work because "<!--" and "-->" aren't comments in
CSS.  They're ignored.  This means that you have a selector 

"File: copstyle.css Author: David Pardy for the Change of Pace website 10-3-2003
body"

which is not a valid CSS selector.  Use /* and */ to delimit CSS comments.

I don't see any use of height=97% in the page.  But if there were, you should be
aware that the CSS spec requires that percentage heights are used only if the
containing block has a defined height.  (This doesn't necessarily apply to HTML
heights, though.  However, please keep one issue per bug.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.