If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla chrome registry deleted manually - now cannot install mozilla

VERIFIED INVALID

Status

SeaMonkey
Installer
--
critical
VERIFIED INVALID
15 years ago
13 years ago

People

(Reporter: Ioannis, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; es-es; rv:1.3) Gecko/20030327 Debian/1.3-4 - es

I unistalled mozilla some time ago and I deleted the chrome registry and other 
mozilla-related files thinking I wouldn't need them.

Reproducible: Always

Steps to Reproduce:
1. rm -rf /usr/lib/mozilla
2. rm -rf /var/lib/mozilla
3. apt-get install mozilla

Actual Results:  
Now, each time I try to install it, appears a message saying:

Updating mozilla chrome registry...mv: cannot 
stat '/usr/lib/mozilla/components/*.dat': File or directory does not exist
mv: cannot stat '/usr/lib/mozilla/chrome/*.rdf': File or directory does not 
exist
done.

This happens with 4 packages:
- mozilla-browser (1.3-4)
- mozilla-mailnews (1.3-4)
- mozilla-psm (1.3-4)
- mozilla-xft (1.3-4)

When I try to launch mozilla, it just exits.

Expected Results:  
Mozilla should have installed correctly and had rebuilt the chrome registry.
Um.. You uninstalled Mozilla and that did not remove the chrome registry?  Is
that part of a different package?

It looks to me like you just manually deleted part of a package that the Mozilla
packages in question depend on and now the apt script running during the install
is confused.  But none of that has anything to do with the Mozilla installer, in
any case -- you're not using it.  At no point does Mozilla say anything like
"Updating mozilla chrome registry" during install or operation, so that message
is from the install script.

So this is either a Debian packaging problem or a problem caused by removing
files that the Debian Mozilla packages need without uninstalling the relevant
package.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
v invalid
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.