When I started Mozilla Mail I lost a lot of messages from Inbox

RESOLVED WORKSFORME

Status

MailNews Core
Database
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Peter Forgacs, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; hu-HU; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Win98; hu-HU; rv:1.3) Gecko/20030312

I found a very interesting and very serious bug.

When I started Mozilla Mail I lost a lot of messages from Inbox. My first
(oldest) 20 - 30 mail dissapeared. Then I saw Inbox with text editor. I saw this:
"
////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////////////
////////////////////////////////////////////////////////////////////AAABuQAA
AAAAAAAAAAAAAAAAAAAAAAAA


------=_NextPart_000_0011_03BF99E9.CDFD2001
Content-Type: video/mpeg
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="00000346.mpeg"

AAABuiEAAQABgAb9AAABuwAJgAb9BeD/wMAgAAABvgjfD///////////////////////////////
"
and etc.


But a good Inbox looks like this:
"
From - Thu Oct 03 15:26:07 2002
X-UIDL: 1033637624.11342_0.----.----.hu,S=860
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
Return-Path: <----@----.hu>
Received: from mail.----.hu (----.----.hu [193.---.---.1])
	by maya.----.hu (8.11.6/8.11.6) with ESMTP id g939Xhb11331
	for <----@mail.----.hu>; Thu, 3 Oct 2002 11:33:43 +0200
"
and etc.

I think my "bed" Inbox has no correct head. I think my Inbox lost the first few
kbyte or some mail overwrote my first few mails.


When I found this bug (when I started Mozilla Mail) I saw that the Mail program
tried build mail information database.

I have already met this bug twice.
My Inbox is 45 Mbyte big.
My newest mails remained correctly.
There wasn't any problem with Mozilla Mail or Window before this datalost happened.

Reproducible: Couldn't Reproduce

Steps to Reproduce:

Comment 1

14 years ago
i think we need more info to be able to reproduce this. perhaps you could check
if it happens with specific mails etc. otherwise we cant really do anything.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.