Random freeze with RedHat 9

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Ignacio Valdes, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030312

Mozilla 1.2 through 1.4 alpha freeze for no apparent reason while browsing.
There is no apparent pattern, however it is happening frequently, like once
every 30 minutes, usually when on a complex site like www.nytimes.com

Reproducible: Couldn't Reproduce

Steps to Reproduce:
Browse NY Times on the web.
Actual Results:  
Freezes and has to be killed and re-started.

Expected Results:  
Kept going.
(Reporter)

Comment 1

15 years ago
Forgot to mention that this has only happened after installing RedHat 9. Both
upgrading from 8.0 and starting over with a clean install had the same problem.
Previously with RedHat 8.0, all versions 1.2-1.3 worked fine.

Comment 2

15 years ago
are you using an RPM (xft/gtk2) build?
does Mozilla use CPU during the hang?
Keywords: hang
(Reporter)

Comment 3

15 years ago
The default mozilla 1.2 installed via rpm that ships with Redhat 9 has the
problem as do downloaded versions from mozilla.org How do I check that it uses
CPU? -- IV
(Reporter)

Comment 4

15 years ago
It just hung again requiring a kill -9. No pattern. Here is the output from ps aux:

ivaldes   4815  0.0  0.4  4172 1116 ?        S    14:29   0:00 /bin/sh
/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
ivaldes   4821  4.4 18.3 117664 46976 ?      S    14:29   0:24
/usr/local/mozilla/mozilla-bin

Comment 5

15 years ago
> downloaded versions from mozilla.org

there are a couple different versions available from mozilla.org.  Did you grab
an RPM or an installer build (.tar.gz)?

you can see if it uses CPU with "top".  ps reports only the average % CPU used
by the process since it started.
(Reporter)

Comment 6

15 years ago
RPM from Redhat for the default installation of 1.2, the rest were tar.gz I'll
try tops next time, but it looks it is using considerable CPU because the system
is less responsive and it shows up as anywhere from 4 to 18 % using ps aux until
I kill it. -- IV
(Reporter)

Comment 7

15 years ago
According to top, it isn't using any CPU. -- IV

Comment 8

15 years ago
I have the same problem, but I can reproduce it by going to instable.net.  This
site works fine in other browsers and worked fine in rh 8.

Comment 9

15 years ago
I've observed this numerous times - at least 20-30 times/day.

When I strace it, it's stuck on a select()

Comment 10

15 years ago
Suspect this might be a library problem - Evolution 1.2.4 has started doing the
exact same thing.

Both Evolution and Mozilla worked fine on RH 7.3 (same installation).  After
upgrading to 9, things started breaking.

If I get more time I'll endeavour to find out more.

Comment 11

15 years ago
I'm seeing the same problem but I thought I'd add a little more info.  It seems
that it always locks up for me after using the scroll wheel. In other words, I
can make it hang every time I hit nytimes.com just by scrolling up and down the
page.  It will also hang scrolling in the inbox window of the mail reader.  I'm
running Redhat 9 with all the erratas installed.  I'm using mozilla 14b.

Comment 12

14 years ago
wfm with firefox using Reh Hat Linux 9 (Ximian desktop 2 though on top)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040415 Firefox/0.8.0+

Comment 13

14 years ago
WFM on both sites, after google, mozilla.org and mozillazine.org.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040419
Product: Browser → Seamonkey

Comment 14

13 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 15

13 years ago
Michael: this bug doens't have anything resembling useful information a
developer could use to fix the problems described-- and "NEW" bugs in
Browser-General are pretty useless.
Assignee: asa → general
QA Contact: asa → general

Comment 16

9 years ago
RedHat 9 is not supported by RedHat, Mozilla 1.4 also, I can't reproduce it on my Fedora 9/Seamonkey 2 alpha, so i thinks this would be INCOMPLETE.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 17

9 years ago
(In reply to comment #16)
> RedHat 9 is not supported by RedHat, Mozilla 1.4 also, I can't reproduce it on
> my Fedora 9/Seamonkey 2 alpha, so i thinks this would be INCOMPLETE.
> 

Dude, this was originally filed 5 years ago. It is so gone. 
Resolution: INCOMPLETE → FIXED

Comment 18

9 years ago
The fix, if there ever was one and this was not just an aberration, is unknown.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.