Quote tag inserts extra spaces in Print Preview

RESOLVED WORKSFORME

Status

()

Core
Print Preview
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Chris Applegate, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030406
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030406

When viewing a page using the quote tag <q> in Print Preview, extra spaces
will be added. If the line begins with a quote, the extra space is inserted
between the last character of the quoted material and the closing quote mark. If
the line does not begin with a quote, the extra space will be added between the
last unquoted character and the closing quote mark.

Reproducible: Always

Steps to Reproduce:
1. Load testcase.
2. File -> Print Preview
Actual Results:  
Looks like:
Here are two quotes.      "You're better off...."
"You're better off[...].     " Note the[...].
Third and fourth quotes do not use <q>, so they're fine.

Expected Results:  
There should be only one space between the . and the " in the first line.
There should be no space between the . and the " in the second line.

Also tested with current Phoenix nightly.
(Reporter)

Comment 1

15 years ago
Created attachment 120292 [details]
Test Case for <q> and Print Preview

Evidently I do not know how to use HTML in Bugzilla. So here is some HTML in a
file.
(Reporter)

Comment 2

15 years ago
Created attachment 121860 [details]
Screenshot

Cropped image showing the bug in action, based on the html attached above.

Comment 3

14 years ago
Reproduced on build 2004030108
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040301

Confirming, and to add to the above discussion, the extra spaces displayed in
Print Preview do not appear in the printed document (I printed out the attached
testcase on an HP deskjet 3420).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

13 years ago
This appears fixed on recent and current builds for Linux and Windows. Since no
patch is associated with this bug, I believe the appropriate resolution is
worksforme.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.