dot.gov - Cannot navigate through web forms, some fields not recorded

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Doug Denholm, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1) Gecko/20021130

I attempted to submit a complaint using the web forms on the National Traffic
Safety Administration site (http://www-odi.nhtsa.dot.gov/ivoq/) using this
version of Mozilla but found many problems... For example, if you enter the
required "description" of the complaint, it just does not show up when you see a
preview of  your complaint.

I eventually gave up using Mozilla to submit the complaint and tried using
Internet Explorer 5.2 for Mac PowerPC. Not only was I able to successfully
submit my complaint but the navigation through the forms worked very differently
than what I experienced using Mozilla.

This may well be because this important government site is not following the
appropriate standards rather than a bug or deficiency in Mozilla. If the former,
you should contact the NTSA web folks and get them to become standards
compliant. If the latter, you have a bug or two to fix.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www-odi.nhtsa.dot.gov/ivoq/
2. With either encrypted or unencrypted web form start entering complaint using
appropriate Mozilla version.
3. Fill in all required fields including description.
4. Hit proceed.

Actual Results:  
With this version of Mozilla you get a preview of the form you have filled out
where some of the fields you entered (e.g. name and address) are correctly shown
but a number (including the complaint description) are blank.

You are also not correctly handed on to the next form page where you would enter
the details about your vehicle.

Expected Results:  
Using IE 5.2.2 for Mac OS X, everything worked properly. I was able to navigate
through the forms including vehicle details and component details and the
correct entries were shown in the form preview prior to submittal.

Comment 1

15 years ago
Doug, do you see any errors on the JavaScript Console? (You'll see lots of
warnings, ignore those for now.)

Comment 2

15 years ago
Also, Doug, you appear to be using an old version of Mozilla, version 1.2.1.
Please retest using a current nightly build.

Comment 3

15 years ago
Using Moz 1.4a OSX I initially could not enter the complaint form at all. It
turns out I had blocked cookies from one or more .gov entities used by the page.
After fixing my cookie prefs the form worked for me.
Summary: Cannot navigate through the web forms using Mozilla, IE 5.2.2 (5010.1) for Mac works → dot.gov - Cannot navigate through web forms, some fields not recorded
please check if this problem still exists, because we want to get rid of
unconfirmed bugs.
Many bugs in here are strill unconfirmed, because eigher nobody sees the problem
or nobody is able to get to the page because of a required login.

(sorry for the spam)
tech evang june 2003 reorg
Assignee: bc → english-us
Component: US Gov → English US
QA Contact: chrisn → english-us
based on comments this was a cookie blocking issue. wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.