Multiple Messages with Same Subject line from same sender incorrectly marked as Junk

RESOLVED FIXED

Status

RESOLVED FIXED
16 years ago
11 years ago

People

(Reporter: ion, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Opera/7.02 Bork-edition (Windows NT 5.1; U)  [en]
Build Identifier: (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

I installed 1.4a and ran mailnews.


My friend Eric had responded twice to the same message with different text. His 
second message was marked as junk.


The same was true of messages from my teammate Beilene.


Reproducible: Always

Steps to Reproduce:
1. Download mail including multiple messages from the same sender with the same 
subject


2. Review the "Junk" column


3. Open the first message with the little recycling icon



Actual Results:  
There's a mustard-colored banner on the message saying "Mozilla thinks this 
message is junk mail"


Expected Results:  
No flag in Junk column


No banner


I suspect your algorithm was designed to do this. But, as most people send 
messages by replying to old messages, and as I use the "Ctrl+e" function in Send 
Mail myself, it's the wrong rule.


This could result in loss of data if I had a naive inbox rule set up, but I 
don't.
I've run into this on Linux too.... It filtered off some bugmail.  ;)
Assignee: sspitzer → naving
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Filters
Ever confirmed: true
OS: Windows XP → All
QA Contact: esther → laurel
Hardware: PC → All
mass re-assign.
Assignee: naving → sspitzer
(Reporter)

Comment 3

16 years ago
I haven't seen this since that version.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.