crash in imglib2.dll when loading html files with broken img links

RESOLVED DUPLICATE of bug 199021

Status

()

Core
ImageLib
--
critical
RESOLVED DUPLICATE of bug 199021
15 years ago
15 years ago

People

(Reporter: Marco Perez, Assigned: Jim Dunn)

Tracking

({crash})

Trunk
x86
Windows 98
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030401

When opening a file like the first testcase I'll attach (be it via menu,
dragging the file onto the browser window, dragging it onto the mozilla icon or
by doucle-clicking it), Mozilla crashes. The crashes usually occur in
imglib2.dll, but they may also occur in module <unknown>. Those crashes can be
reproduced much more reliably when disconnected from internet. I've experienced
the problem with Moz1.4a, whereas Moz1.3 as well as Phoenix don't seem to be
affected.

Reproducible: Always

Steps to Reproduce:
1. download the first testcase
2. disconnected from internet (otherwise Mozilla may not always crash)
3. open your local copy of the testcase
Actual Results:  
Mozilla crashed and triggered a talkback report

Expected Results:  
it should have displayed two broken (unable to load) images

Can somebody confirm this for other platforms, OSes and for newer builds, please?
(Reporter)

Comment 1

15 years ago
Created attachment 120371 [details]
loading this file locally when offline triggers a crash

This is a minimized testcase. It's a valid html4.01 file which consists mainly
of a broken img link and the w3c validator link with the "Valid HTML" image.
(Reporter)

Updated

15 years ago
Keywords: crash
wfm with win2k build 20030412.. 
Do you have a talkback ID from that crash ?
This was fixed on the evening of April 1 (your build is from before the patch
landed).

*** This bug has been marked as a duplicate of 199021 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.