If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

An additional extension is added to the file being downloaded: pic.jpg.jpeg

RESOLVED DUPLICATE of bug 183653

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 183653
15 years ago
13 years ago

People

(Reporter: alex black, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020721 Netscape6/6.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020721 Netscape6/6.0

Problem 1:
When the image is downloaded Mozilla adds additional extension to the existing
one (based on a mime type image/jpeg the filename is picture.jpg.jpeg).

Problem 2:
Then it displays the "Opening ...." dialog box where it prompts to save it to
disk. If I select to open it with Mozilla and untick "Always show this dialog
before handling files of this type", then it opens it with Mozilla but next time
it still displays "Opening ..." dialogf despite my settings. I checked in the
ehlper applications image/jpeg mime type is correctly registered to be handled
by Mozilla without prompting.

I need to point out that my default application for jpeg images is ACDSEE.


The URL above demonstrates the problem. You need to login username: Mozilla,
password: mozilla

Regards

Alex

Reproducible: Always

Steps to Reproduce:
1.  Go to the URL:
http://www.fordforums.com/attachment.php?s=ef08c6ec033d0622aa124533bf9df52b&postid=372986

2. Login as user: Mozilla with password: mozilla

3. Note the double extension in the "Opening ..." dialog
 
4. Select Mozilla in "open it with" edit box and untick "Always show this
dialog..." checkbox

5. Close mozilla and revisit the URL, yousdhould still see the "Opening..." dialog

Actual Results:  
Addtional extencion is added to the file i.e image.jpg.jpeg
Helper application settings are not utilised as they should - "Opening ..."
dialog is displayed always.

Expected Results:  
If the file already has an extension it is probably better not to add another
one even if Mozilla is confident about the mime type. This proiblem is also
hapenneing  when downloading tar.gz files, mozilla prompts to save these as
tar.gz.tar.

If I select once to open the file automatically without displ;aying "Opening
..." dialog Mozilla shoudl do that.
Please correct your Build ID if you report a bug.
You can't use Netscape 6 becaause Netscape6 is based on 0.9.4 and not 1.1b.
Bug reports from such old builds are also invalid, we accept bug reports only
from the latest milestone..

marking as dupe of bug 184975, this is a error in the vbulletin Board and the
vbulletin developers fixed this in the new Board version.



*** This bug has been marked as a duplicate of 184975 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
@#$%& wrong bug#
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
btw. issue 1) is another bug 

*** This bug has been marked as a duplicate of 183653 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.