reliable.com: Site needlessly redirects Mozilla users to rude 'Upgrade Now' page

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Dan Tobias, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030130

For no logical reason, this site's author has decided to send anybody who tries
to use the site with the "wrong" browser to a rude page that tells you to
"upgrade" to one of a list of choices that bizarrely includes the long-obsolete
Netscape 4.x, which is hardly an "upgrade" from Mozilla.

The site also comes up as a completely blank screen if you have JavaScript
turned off.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL using any Mozilla-based browser.

Actual Results:  
You got redirected to a clueless "upgrade now" page.

Expected Results:  
Let you get into their darned site.

Bizarrely enough, Opera, set to identify itself honestly, has no problem getting
into the site, since the author didn't bother to try detecting it.

Comment 1

15 years ago
This is not a Mozilla bug. This is a problem with the admittedly clueless
webmaster of that site. 

If it's absolutely vital that you use their broken website, change the user
agent that Mozilla sends. Info on how to do that is here:

http://www.mozilla.org/unix/customizing.html
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 2

15 years ago
Marking Invalid.
(Reporter)

Comment 3

15 years ago
I filed this bug in the "Tech Evangelism" section, which is, as far as I am
aware, intended for use to point out clueless webmasters needing to be given a
clue.  Why then is it considered "invalid"?

Comment 4

15 years ago
Dan you are absolutely correct.  -> REOPEN

Christopher, please do not mark Tech Evangelism bugs invalid. If you have any
questions regarding Tech Evangelism contact me or come to #evangelism on irc.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 5

15 years ago
confirm
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

15 years ago
Oops, I neglected to look in what section it was filed. Completely my fault.

My apologies. 

Comment 7

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us
(Reporter)

Comment 8

14 years ago
The site in question has been redesigned, and no longer redirects Mozilla users
to the rude "upgrade your browser" page.
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.