Status

()

Core
XUL
RESOLVED DUPLICATE of bug 161956
15 years ago
9 years ago

People

(Reporter: Jonathan Baron, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030412
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030412

With the following screen resolution:
  dimensions:    1600x1200 pixels (350x261 millimeters)
  resolution:    116x117 dots per inch
The fonts in the user interface are very tiny.


Reproducible: Always

Steps to Reproduce:
1. start Mozilla (the ..i686-pc-linux-gnu.tar.gz version)


Actual Results:  
tiny font, probabaly 12px - hard to tell exactly



Expected Results:  
same font as Gnome or other settings
(Note, I get the expected results when I use the RPM of 1.4a, but
that has other problems so I went back to the linux-gnu.tar.gz version.)


This can be fixed by copying the /mozilla/defaults/profile/chrome
 userChrome-example.css to ./mozilla/default/chrome/userChrome.css
(for example) and uncommenting the lines
 * {
  font-size: 20px !important
 }
But I don't think this should be required.  (And, if it should,
there should be a preference for it.)

Comment 1

15 years ago
is this a dupe of bug 161956 or bug 194500 ?
(Reporter)

Comment 2

15 years ago
I did find both of those bugs, and for some reason I thought this was
different.  Now that I look again, I see that this one is probably the
same as 161956.  Perhaps the problem was that my file was originally
called usrChrome.css.  Recently it has changed to userChrome.css.  So
when I tried the instructions in 1619956 they didn't work, and I dismissed
that bug as being irrelevant, then rediscovered the same thing.  So, yes,
this does look like a duplicate of 161956.

But I don't think it is the same as 194500.  I had tried that too, and
changing my prefs.js file as indicated did nothing, and there was nothing
about this indicated in about:preferences.  (Well, it may be the same bug,
but that path to a solution seems to be a dead end right now.)

Sorry for not being more careful.  But I did try.  (I had read both of
those.)

Also, this has been a problem for a while.
Depends on: 161956

Comment 3

12 years ago
Looks like reporter switched from RedHat XFT/GTK2 RPMs to Mozilla.org GTK1 builds. GTK1 builds do fix UI fonts at 12px, while XFT/GTK2 builds use the system CSS font "menu", which in RedHat/Fedora can be set in gnome-control-center. 12px @ 1600x1200 is tiny unless you use a very large display.
(Reporter)

Comment 4

12 years ago
I don't think that #3 is correct about the sequence of events.  But
I've now installed Firefox on several different computers and have
not felt that there was any big problem.  (All my computers have
high-resolution monitors.)  Thus, it is OK with me if this is changed
to FIXED, or WORKSFORME, or whatever.

Updated

9 years ago
Assignee: jag → nobody

Comment 5

9 years ago
Since expiration of GTK1 this is no longer relevant. Based on comment 2 I think it best to mark dupe of bug 161956
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 161956

Updated

9 years ago
No longer depends on: 161956
You need to log in before you can comment on or make changes to this bug.