expedia uses javascript cookies

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: jgbittar, Assigned: darin.moz)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030401

when you go to expedia.com and try to access my profile or my trips which
required the site to set a cookie in your machine the site says that cookies are
not enabled when in fact they are.

Reproducible: Always

Steps to Reproduce:
1.go to expedia.com
2. selcct my trips or profile
3. you will get the error that cookies are not set

Actual Results:  
the site takes you to a page that says cookies are not enabled

Expected Results:  
go into the profile

Comment 1

16 years ago
I had some effects like this with other prefs.
Could you please try:
your prefs are saying that cookies are enabled so 
- disable them, close prefs, reopen prefs, are they shown as disabled?
you could try to access the website now, to verify they are disabled or just go
on to next step:
- enable them, close prefs, reopen prefs, are cookies shown as enabled?

You can´t do this with Tools/CookieManager because it gives you only one option
to select from Block or Unblock, the other is greyed out.
But you can verfify that these offer corresponds to the settings you find in
Edit/Preferences/Privacy&Security/Cookies
Please report your findings, wether that helps, or not.
(Assignee)

Updated

16 years ago
Whiteboard: DUPEME?

Comment 2

16 years ago
reporter: are you able to test a more recent build? the problem has most likely
been fixed.

thanks!
(Reporter)

Comment 3

16 years ago
Repeated all procedures indicated below, and the problem persists.  Turning on 
and off the cookies as indicated below to no avail. I have been forced to use 
ie when going to that site which is quite often, a really not a convinient 
manner of operating. please look into it. thanks

Comment 4

16 years ago
wfm on 1.4a.

reporter: please list your cookie and javascript prefs.

Prefs->Privacy & Security->Cookies
Prefs->Advanced->Scripts & Plugins
(Reporter)

Comment 5

16 years ago
cookies enabled limited lifetime of cookiea to current session

javascript is enabled for Navigator, scripts are not allowed to do anything, 
plug ins are enabled for mail and newsgroups

Comment 6

16 years ago
uh, scripts aren't allowed to do anything?

try allowing scripts to "create or change cookies" and "read cookies". you'll
need that enabled for a lot of sites to work with cookies correctly.
(Reporter)

Comment 7

16 years ago
done it works ok now, create or change cookies did the trick does not need the
other one. thanks

Comment 8

16 years ago
great. ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

16 years ago
Problem resolved as indicated below
Status: RESOLVED → CLOSED

Updated

15 years ago
Summary: when trying to go in to the profile or my trips at expedia the site does not seem to know that the in the preferences cookies are set to to be accepted → expedia uses javascript cookies

Comment 10

15 years ago
REOPEN (to go to VERIFIED, we don't used CLOSED).
Status: CLOSED → UNCONFIRMED
Resolution: INVALID → ---
Summary: expedia uses javascript cookies → expedia uses javascript cookies
Whiteboard: DUPEME?

Comment 11

15 years ago
While I'm here, I'll just ask:

We seen to get a lot of these bugs for different sites, should we change the
summary to make this easier to spot somehow?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.