The quoted word "anchor" should be green, NOT purple, since it's part of an anchor. It's a named anchor, and styles declared for the A tag are applied to them under CSS1. It also should NOT turn orange when clicked upon.

RESOLVED DUPLICATE of bug 200195

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 200195
15 years ago
13 years ago

People

(Reporter: Juan, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-AR; rv:1.3) Gecko/20030312

The quoted word "anchor" should be green, NOT purple, since it's part of an
anchor. It's a named anchor, and styles declared for the A tag are applied to
them under CSS1. It also should NOT turn orange when clicked upon.
This is in the middle of the page, so according to the w3c mozilla is not
handling correctly this style.

Reproducible: Always

Steps to Reproduce:
1.just click on the named anchor, it turns to maroon
2.
3.

Actual Results:  
the named anchor turns marron on click,

Expected Results:  
the named anchor should remain green

spanish pack(argentinian), modern theme

Comment 1

15 years ago
The quoted word *is* green, and does *not* turn orange when clicked. According
to CSS, active anchor tags are instructed to turn maroon, and that is the
behavior being exhibited. So where's the problem?

Bug should probably be marked as invalid, but I'll wait for further review.

Comment 2

15 years ago
Mozilla is a CSS2 browser.  The page is written to test CSS1.

Mozilla is correctly rendering the CSS according to CSS2 rules.  The rules for
:active differ between CSS1 and CSS2.

*** This bug has been marked as a duplicate of 200195 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.