If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Arrow keys and copy paste has recent problems

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Arne Falk, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030412
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030412

The arrows keys left and right dont work in the URL field, or in any other field I have tried. Also the cut and paste with CTRL-C and CTRL-V dont work. This has happend during the 1.4b cycle.


Reproducible: Always

Steps to Reproduce:
1. GOTO URL Field, USE LEFT and RIGHT keys to navigate
2.
3.

Actual Results:  
No action at all

Expected Results:  
Cursor movement

Comment 1

15 years ago
wfm, tested on this URL, BuildID 2003041208 on Win98SE
I´ve got to click twice to set a cursor, and the can move it using the separate
Arrow Keys or the Arrow Keys from the NumPad.
When did you note this behaviour?
After upgrade install, or install of an extension?

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030412
(Reporter)

Comment 2

15 years ago
I thought it was after an upgrade, but since you mention extensions it *could* have happened after installing calendar. Can I uninstall calendar easily to test ?
(Reporter)

Comment 3

15 years ago
I removed the mozilla.org and installed the same build again and the problem
disappeared. Should I mark as invalid ?
Yes, please do.

Comment 5

15 years ago
No, because it is a bug. You can verify that installation of calendar leads to
this bug, and adjust Summary accordingly, so people looking for calender find
this  bug.
Would "Calendar blocks Mozilla Arrow Keys and Copy&Paste" be a good and correct
summary ?
Is it a bug in Mozilla, because Mozilla Keys don´t work, when Mozilla has focus,
or is it a bug in Calendar, because the keys are not working if Calendar has focus?

Comment 6

15 years ago
I'm seeing the same thing on Build ID: 2003042208 on Win XP.

I have Calendar installed but see the issue even without running Calendar. It does not seem to be a focus issue since it occurs without Calendar running. 

Everything was fine until I updated to  a recent nightly build. The only change made was updating Mozilla. Calendar was already installed before the update and the arrow keys and cut and paste worked properly.

Comment 7

15 years ago
Same issues with arrow keys, cut-paste (keyboard, edit menu or right click),
Home/end also didn't work.
 
Calendar was previously installed.
Upgraded to 1.4 Alpha, problems appeared.
Upgraded to 2003051008 nightly, no change in problems.

FIXED: Upgraded to latest version of calendar, fixed all issues with cursor
movement/cut paste.

Comment 8

15 years ago
I think I'm having the same problem.  At least arrow keys, home/end, and page up/down don't work anywhere.  I do have calendar installed also.  I'm also have many other serious problems:

- spaces don't work right (I just filed a bug: 205250 on this a few minutes ago)
- backspace (go back) doesn't work
- can't get preferences to take (new blank/home/last page settings at least)
- can't compose mail
- can't copy/paste

This thing is quite unusable right now.  There are probably many other problems.

I'm going to try installing an updated calendar or remove the old one to see if that works.

Comment 9

14 years ago
I have seen this bug frequently with many different builds of Seamonkey,
Firebird, and Thunderbird over the past few months. I have never had calender
installed at all.

arrow keys and other navigation keys cease to work in the url bar and all text
entry fields, and they do not start working again until I press CTRL+N to create
a new browser window. I then close the new browser window, and the arrow keys
start working again in my original browser window (of course, when using
thunderbird, I am screwed)

I cannot see any pattern to what triggers this bug, other than that I usually
first notice it when editing the url bar or typing in a <textarea>
(Assignee)

Comment 10

14 years ago
Unable to reproduce with Mozilla 1.7 Alpha on windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.