keyboard input: getting cyrillic letter GHE instead of cyrillic letter ZHE

VERIFIED DUPLICATE of bug 193831

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 193831
15 years ago
15 years ago

People

(Reporter: Vladimir Volovich, Assigned: smontagu)

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030319
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030319

in Solaris 8 sparc, running CDE, i'm unable to input the cyrillic letter ZHE
from keyboard within Mozilla (e.g. to fill the form, etc) - i'm getting the
cyrillic letter GHE instead (for both uppercase and lowercase). in other
applications like dtterm, there's no problem. all other cyrillic letters work
fine in mozilla, too.
the cyrillic letter GHE is thus duplicated - it appears both when pressed the
dedicated key for GHE, and when pressed a key where ZHE is supposed to be input.

i'm able to paste the cyrillic letter ZHE via clipboard from e.g. dtterm, but
i', unable to enter that letter directly in mozilla.

Reproducible: Always

Steps to Reproduce:
1.focus in any form text field, or in location bar
2.switch to russian keyboard input
3.press the key with the cyrillic letter ZHE
Actual Results:  
cyrillic letter GHE appears

Expected Results:  
cyrillic letter ZHE appears

Updated

15 years ago
OS: SunOS → Solaris

Comment 1

15 years ago
What's letter GHE and ZHE looks like? cc marina.
(Assignee)

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 193831 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.