Last Comment Bug 202016 - Print Preview of XUL menubar crashes Mozilla 1.3 and Netscape 7.0
: Print Preview of XUL menubar crashes Mozilla 1.3 and Netscape 7.0
Status: RESOLVED DUPLICATE of bug 195721
:
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Windows 2000
: -- critical (vote)
: ---
Assigned To: David Hyatt
:
: Neil Deakin
Mentors:
http://pos-x.onsitetech.com/menus.xul
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-14 14:09 PDT by Curtis "Ovid" Poe
Modified: 2008-07-31 03:12 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
win2k 20030413 optimized with symbols stack trace (2.72 KB, text/plain)
2003-04-14 15:00 PDT, Matthias Versen [:Matti]
no flags Details

Description Curtis "Ovid" Poe 2003-04-14 14:09:52 PDT
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

Accessing an XUL menu and then selecting File | Print Preview causes Mozilla 
1.3 and Netscape 7.0 to crash on Windows 2000.  This has been tested on two 
different computers, both running Windows 2000.  I am not certain about other 
operating systems.

Reproducible: Always

Steps to Reproduce:
1.  Go to http://pos-x.onsitetech.com/menus.xul
2.  Select File -> Print Preview
3.  Cry when browser crashes

Actual Results:  
An OK/Cancel error box pops with with the title "mozilla.exe - Application 
Error".  The text of the error message is:

'The instruction at "0x616704bc referenced memory at "0x00000000".  The memory 
could not be "read".'

Expected Results:  
The print preview window should have been launched with the menu bar correctly 
displayed.

I have also verified that I can reproduce the problem with the following 
minimum XUL test case:

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<window
    id="test"
    title="Test Print Preview"
    xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
    xmlns:html="http://www.w3.org/1999/xhtml">
    
    <toolbox>
        <menubar id="some-menubar">
            <menu id="file-menu" label="File">
                <menupopup id="file-popup">
                    <menuitem label="New" />
                </menupopup>
            </menu>
        </menubar>
    </toolbox>
</window>
Comment 1 Matthias Versen [:Matti] 2003-04-14 15:00:11 PDT
Created attachment 120491 [details]
win2k 20030413 optimized with symbols stack trace
Comment 2 Matthias Versen [:Matti] 2003-04-14 15:01:35 PDT

*** This bug has been marked as a duplicate of 195721 ***

Note You need to log in before you can comment on or make changes to this bug.