Envelope is displayed as text ( with gray background ) can't access attachments

VERIFIED DUPLICATE of bug 195374

Status

--
major
VERIFIED DUPLICATE of bug 195374
16 years ago
14 years ago

People

(Reporter: ron_shp, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030412
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030412

After installing a 1.4 build the mail message pane stopped displaying properly.
 The envelope is now displayed as text w/gray background no separate box to
access/save any attachments.  Envelope display can be restored by switching the
profile  ( in this case a profile without any e-mail accounts), starting an
e-mail account setup, canceling after second dialog and then switching back to
the original profile, mail enveope is now displayed properly.  However it
reverts back to the broken state if browser is restarted.  ( this is the second
time this happened ... the first time I deleted all the accounts and created new
ones...then repopulated the folders with the old data minus the .msf files to
allow browser to recreate the indexes )

Reproducible: Always

Steps to Reproduce:
1.Setup a profile with multiple POP email accounts. insuring that the e-mail 
accounts have data with attachments and check mail display.  Envelope is
displayed as an expandable box with a "+" or "-" next "Subject" and attachments
are in a box to the right.
2.re-install 1.4 mozilla ( different  build?)
3.Check mail 
   - envleope is now plain text ( not expandable, no links )  with different
gray background.  The box to the right is missing and attachemnets are not
accessable via the UI.
4. switch profiles and use one without any mail accounts.
5. select "Mail&Newsgroups" 
6.  Follow first two dialogs to create an account
7. Cancel the account setup
8.  Switch back to original profile
9. Access and check mail 
   - the box with attachemnts is back and the envelope is properly displayed,

Actual Results:  
Did this twice with the same results.  Once going from 1.3 -> 1.4 and the second
time going from 1.4 to a newer 1.4 build.  

Expected Results:  
Displayed the envelope properly after an install onto and existing installation.

This is the second time this happened ... the first time I deleted all the
accounts and created new ones...then repopulated the folders with the old data
minus the .msf files to allow browser to recreate the indexes.  This was painful
process and I would prefer not to have to do this again.  I could not find any
bell, button, knob nor menu option that would turn the envelope display back on.

Comment 1

16 years ago
Ronda Shpeer: This appears to be a duplicate of bug 195374.  Do you agree?

Further, I saw a message in the newsgroups today about this:
netscape.public.mozilla.mail-news, "Composition window/Preferences in Mozilla", 
in which Matthias Versen wrote:
> Close Mozilla, locate your Mozilla-Profile (see the 1.3 Release notes
> for the path) and rename the file "abook.mab".
> If it now works try to fix your Mozilla Adressbook-File in a text-Editor
> and rename it back.
Summary: Envelope is displayed as text ( with gray background ) can't access attachments → Envelope is displayed as text ( with gray background ) can't access attachments
(Reporter)

Comment 2

16 years ago
I tried the suggested fix and indeed moving and renaming the abook.mab fixed the
symptoms.  So it does seem that this is a duplicate of bug # 195374.  I found
that the abook.mab file had garbage ( non-ascii, unreadable as text )at the end,
once that was eliminated then I could use it again. Since everything worked
prior to the upgrade/install, I think it is reasonable to suggest that something
in the install process corrupted the address book and that should be investigated.  
(Reporter)

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 195374 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
A fix was checked in yesterday; see Bug 106461 comment 55.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.