Wish: "top 10" pulldown

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
19 years ago
8 years ago

People

(Reporter: lucas, Unassigned)

Tracking

({helpwanted})

Trunk
All
Other
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I posted the following enhancement request on netscape.public.mozilla.wishlist
and got a few hearty amens, including one suggesting I post this is an
enhancement request here.  Note that I am submitting this to bookmarks instead
of browser-general because it is basically a self-editing kind of bookmark list.

My wish: a pulldown for your top ten sites.  The pulldown is calculated, not
edited by the user.  Items are listed in a static order so that the user doesn't
have to read through the list every time.  New items always appear at the end of
the list, in place of the previous last place item.

The most useful improvements are in the most used features.  A feature that made
it 10% easier/faster/more efficient to get to the urls you use most will likely
save much more effort than a feature that makes it 90% to get to infrequently
used urls.  (This assumes a strongly lopsided use of favorite sites, which I
believe is usually the case).  Mozilla should be able to take advantage of this.

Instead of a pulldown the list could appear in a pane or a toolbar.  What's
important is to  spend real estate where it will have the greatest effect.

- Lucas Gonze
(Reporter)

Comment 1

19 years ago
I notice a contradiction in my request:

> Items are listed in a static order so that the user doesn't
have to read through the list every time.  New items always appear at the end of
the list, in place of the previous last place item.

If items are in static order, the last item on the list will not be the least
most visited site.  I suggest instead that new items show up in place of the
item they are replacing, so that the overall list order is preserved and users
are not required to relearn any items but the new one.

Updated

19 years ago
Assignee: slamm → don
Whiteboard: HELPWANTED
Target Milestone: M20
You'd want to try and avoid bookmarked sites appearing or at least those in the
personal toolbar already.

Updated

19 years ago
Keywords: helpwanted

Comment 3

19 years ago
Other potential gotchas:

* Would the content and order of the list settle down quickly enough, for your
  average user to bother waiting until the position of each site in
  the menu is reliable enough for the menu to be used?

* How are the top ten sites going to be recorded? Presumably using the browser
  history. Since for most users the history expires pretty quickly (9 days being
  the default), is the list going to be stable enough to be usable?

* Where, in the already-cluttered interface (I already have a window history
  pull-down in the Go menu, a bookmarks pull-down in the bookmarks menu, and a
  recently-typed-addresses pull-down in the location bar), is this going to go?
  Will I be able to manually edit this list, in the event that one of my top ten
  sites moves and I can't wait the 4~5 days the list will take to catch up? And
  will I be able to specify that I want 12, or 6, items instead of 10? If so,
  how?

Unfortunately, these problems can't really be evaluated without someone actually 
implementing the idea first. :-)

Comment 4

19 years ago
I'd have to recommend a pass on this feature. This 'automatically genetated'
list of URLs would be changing entries/order too much to be of use. The user
would have to open the menu and read each entry down, because what their looking
for could very well have moved. There is no advantage of seperating this from
the normal bookmarks. How my bookmarks are setup is basically my 'Top 6' at the
top, then a divider, then the rest. These top 6 are in the order I want, and
dont ever move... I also dont have my next top 4 sites there taking up space.
It's alot quicker to manually bookmark your favorite sites and order them how
you want at the top of the list, then it would be to wait for your top 10 to
settle.

Comment 5

19 years ago
Move to "Future" milestone.
Target Milestone: M20 → Future
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 7

18 years ago
I remember reading that alecf is working on something similar for the history --
am I wrong?
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-

Comment 9

18 years ago
this could be done SO easily with the search datasource, and constructing a
search url to this effect.

the only trick is limiting the number of search results to the last 10 or so, so
you'd have to extend the search url syntax slightly. 

the same hack could apply history, since the search datasource can search any
other datasource.

Comment 10

18 years ago
over to alecf
Assignee: vishy → alecf
Product: Browser → Seamonkey
Assignee: alecf → nobody
Priority: P3 → --
QA Contact: claudius → bookmarks
Whiteboard: HELPWANTED
Target Milestone: Future → ---

Comment 11

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 12

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Comment 19

8 years ago
Extension fodder.
Resolution: EXPIRED → WONTFIX
You need to log in before you can comment on or make changes to this bug.