bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Proxy: Cannot access Microsoft Outlook Web Mail




15 years ago
14 years ago


(Reporter: José Jeria, Assigned: Darin Fisher)



Windows 2000

Firefox Tracking Flags

(Not tracked)



(4 attachments)



15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

I noticed that after 1.3 its not possible to access MS Outlook Webmail anymore.
I use a portable and can with no problem access the webmail from an office
without a proxy, but if any proxy then i cannot login.

This works fine in Mozilla 1.3, but since then its not possible, tried 1.4a, and
nightly build (12 april) with no luck. 

Also creating new profile doesnt help. Nor does a total clean installation.

Reproducible: Always

Steps to Reproduce:


15 years ago
Keywords: regression

Comment 1

15 years ago
jose: can you please provide a HTTP log by doing the following:

open a DOS prompt and type:

C:\> set NSPR_LOG_MODULES=nsHttp:5
C:\> set NSPR_LOG_FILE=c:\log.txt

then run mozilla from the very same DOS prompt:

C:\> cd \path\to\mozilla
C:\path\to\mozilla> .\mozilla.exe

now repro the problem and exit mozilla.  then upload log.txt to this bug report
or feel free to email it directly to me.  thx!

reassigning to me
Assignee: asa → darin
Component: Browser-General → Networking
QA Contact: asa → benc

Comment 2

15 years ago
Created attachment 121523 [details]
Log file

Ok, did as you said, tried to login 3 times and then the last time I pressed
cancel to dismiss the password popup.

Comment 3

15 years ago
I see what looks like the same problem but without using a proxy. I can send
differential HTTP logs from 1.2.1 (works) and 1.4.a (fails) if that's useful.


15 years ago
Severity: normal → major

Comment 4

15 years ago
thanks for the log file!  ok, there is something wierd going on in this snipet:

2184[d7aab0]: nsHttpConnection::OnSocketWritable [this=1f71420]
2184[d7aab0]:   writing transaction request stream
2184[d7aab0]:   ReadSegments returned [rv=0 read=708 sock-cond=0]
2184[d7aab0]:   writing transaction request stream
2184[d7aab0]:   ReadSegments returned [rv=0 read=0 sock-cond=0]
2184[d7aab0]: nsHttpTransaction::OnSocketStatus [this=1b76a88 status=804b000a
2184[d7aab0]: nsHttpTransaction::OnSocketStatus [this=1b76a88 status=804b0006
2184[d7aab0]: nsHttpConnection::OnSocketReadable [this=1f71420]
2184[d7aab0]: nsHttpConnection::CloseTransaction[this=1f71420 trans=1b76a88
2184[d7aab0]: nsHttpTransaction::Close [this=1b76a88 reason=0]
2184[d7aab0]: restarting transaction @1b76a88

notice that the connection becomes writable and we write out the last part of
the NTLM request... that should be good enough to get a 200 OK response. 
however, when we go to read (OnSocketReadable), we apparently find that the
socket is closed!  this is unexpected and so mozilla restarts the transaction on
a new connection, and then the cycle repeats.

José: can you please re-capture the log file, but with this slight modification

  set NSPR_LOG_MODULES=nsHttp:5,nsSocketTransport:5

this will hopefully reveal more about why the socket appears to be closed.

Tony: yes, if you can provide log files as well that would be very useful. thx!
Flags: blocking1.4?
Priority: -- → P2
Target Milestone: --- → mozilla1.4beta

Comment 5

15 years ago
Created attachment 122583 [details]
Requested log-file

Same as before but with:
set NSPR_LOG_MODULES=nsHttp:5,nsSocketTransport:5

Pressed OK twice and then Cancel

Comment 6

15 years ago
Created attachment 122587 [details]
Sucessful https MS Outlook logon on Mozilla 1.21

Comment 7

15 years ago
Created attachment 122588 [details]
Failed MS Outlook logon on Mozilla 1.4a

Comment 8

15 years ago
FYI - the above two attachments were not created on the same machine. The failed
1.4a one is on Windows NT4, and the working 1.2a is on Win2K. They are on the
same network, without a proxy, but behind a NAT box. Probably insignificant, but...

Comment 9

15 years ago
Darin, can you take a look at the new log and see what it looks like. Is there
any chance of a low-risk fix to this. 

Comment 10

15 years ago
Ok, here's a question:  how are you entering your username and password?

Since you said this works with Mozilla 1.2.1, I suspect you are entering your
username and password.  However, since Mozilla 1.4 beta now supports Microsoft
NT LanManager (NTLM) authentication, you need to enter more than just your
username and password.  For the username you need to enter "Domain\Username".

I know that our UI for the authentication prompt fails to mention the fact that
you should do this, and that is definitely something we need to fix.

Comment 11

15 years ago
Darin, this works fine in Mozilla 1.3.1
In version 1.4a this did not work anymore. 

I use the same method as 1.3.1 to login:

Comment 12

15 years ago

ok, thanks for the info.  i'm a bit stumped then.  i'm not sure we should be
falling back on Basic auth if NTLM auth fails.  hmm...

just so you know if you want to get around this problem temporarily you can try
removing a line from your installation's compreg.dat file found in the
components subdirectory.  the line to remove is this:


if you remove that then Mozilla 1.4 should start acting like 1.3.  in the
meanwhile i'm not sure what to ask you to try next... maybe it would help to see
network traces from IE and Mozilla side by side.  if you are willing to spend
the time to do this, then that would be great.  to capture a network level
trace, you will need to use a tool like the one from www.ethereal.com.  you can
use that tool to capture network packets, and then you can save the results out
to a file.  if you could email me the results that would be great.  you probably
don't want to attach them to the bug since they may contain sensitive
information.  if you send me your logs i will be sure not to share anything
sensitive on the internet.  thanks!

Comment 13

15 years ago
About "capture a network level trace". I might have time to do this end of next

Tony, do you have any time to help out with this?

Comment 14

15 years ago
Yes, removing that line in compreg.dat helped. 

Mailed you 2 files containing 2 network level traces, one succesful one with
1.3.1 and one that failed with todays build (21 May 2003).

Comment 15

15 years ago
Do you know what kind of server environment this is? Is this something that runs
on Win2K?

Comment 16

15 years ago
You mean the exchange server? Then yes, its win2k.

Comment 17

15 years ago
mozilla1.4 shipped. unsetting blocking1.4 request.
Flags: blocking1.4?

Comment 18

14 years ago
Jose: is this still a bug in Mozilla 1.7 / Firefox 0.9 ?
Priority: P2 → --
Target Milestone: mozilla1.4beta → ---

Comment 19

14 years ago
Darin, when I experienced this, I was working temporarly in another office. I
dont work there anymore, so its impossible for me to test this again. Feel free
to close this bug if nobody else can confirm it.

Comment 20

14 years ago
I experienced the same problem going from Mozilla 1.3 to 1.4, but now it works
OK in Firefox 0.9.1.  So for me it looks as if it is fixed, although I can't
recall the exact rev when it started working. 

Comment 21

14 years ago
thanks for the quick responses, and sorry that i lost track of this bug! 
marking WORKSFORME based on previous comments.
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 22

14 years ago
Ironically, I think we use this at my new workplace, so in the future, I can
probably test this.
Summary: Cannot access Microsoft Outlook Web Mail when using proxy → Proxy: Cannot access Microsoft Outlook Web Mail
You need to log in before you can comment on or make changes to this bug.