bookmark menu stays "on top" after I drag-move a bookmark inline

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: alexdedov, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

When a bookmark from the main list is dragged into any bookmark sub-folder
("Mozilla Project", for example) then that secondary window occasionally stays
on top of the screen even after the main list disappears.

Reproducible: Always

Steps to Reproduce:
1. drag any bookmark from the main list into any bookmark sub-folder ("Mozilla
Project" for example)
2. after the bookmark is copied, move mouse straight up to the top menu bar
3. and then to the left, over any menu option

Actual Results:  
main drop-down list of bookmarks disappear, new drop-down menu appears, while
secondary bookmark menu remains open on top of the screen. minimizing browser
window leaves that menu floating over desktop or other app windows.

Expected Results:  
hide close secondary bookmark list

ouch, after that, if Mozilla is the only open window, it refuses to get
minimized - comes right back up.

Comment 1

16 years ago
Since the status is still UNCONFIRMED after nearly two months, I am submitting a
second repro scenario (just in case the original one was unclear):

  1) Click the "Bookmarks" drop-menu.
  2) Drag-and-drop a bookmark from the main folder into a sub-folder
     so that it expands to the right of the arrow.
  3) Let go of the mouse and press the left arrow on your keyboard 
     twice so that the menu focus goes from the item you dropped,
     to the "Bookmarks" menu, and then to the "Go" menu.
  4) Now, move your mouse away from the sub-menu and it will 
     remain on top.

You can "close" the bookmark sub-menu by going to the "Bookmarks" menu, clicking
on the parent folder that normally summons it, and then clicking on another folder.

You can also "close" the bookmark sub-menu by clicking on an entry within it
(and going to the bookmarked page).

I ran this repro on Win XP PRO with Mozilla 1.4 RC1.

Comment 2

15 years ago
I am seeing the same issue in a recent build of Firefox:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040318
Firefox/0.8.0+

In my case, the steps that reproduced it were:
1.  Open the bookmarks menu
2.  Drag and drop a bookmark from the root level to a subfolder
3.  with the bookmarks menu still open, click on a bookmark in the root level

The root bookmarks menu closes but the subfolder where you dragged the bookmark
in step 2 stays open.

Comment 3

15 years ago
I'll pile on here.  

I've seen this behavior in Moz 1.6 when I drag the link from the Address bar,
into the Bookmarks Menu item and into a subfolder.  After dropping the link into
the subfolder, the primary bookmark menu disappears, but the sub-folder remains
open.

BTW, to the others who reported this, perhaps adding votes would help?   

Comment 4

14 years ago
Created attachment 157050 [details]
testcase illustration (animated GIF)

Works on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.2) Gecko/20040806
(and lots of previous versions).

Updated

14 years ago
Attachment #157050 - Attachment description: testcase illustration → testcase illustration (animated GIF)

Updated

14 years ago
Blocks: 212769
Product: Browser → Seamonkey

Comment 5

14 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

13 years ago
Created attachment 187590 [details]
A deep recursive bookmark tree for testing the bug

Attaching testcase from bug 177547 for this bug. (Which was subsequently duped
to bug 160082, which honestly I think was rather obscure)

I'd mark as duplicate, but if I mark it towards that bug I worry that it'll be
lost to obscurity again. Does anyone have any suggestions?

Steps to reproduce using the testcase (as a clean bookmark tree):
Steps to reproduce (I'm using the test case to clearly show this, you can
reproduce it using some guessing and a deep folder tree):
1. Travel through all the new folders until you reach the deepest depth.
2. Drag and drop the bookmark to the "copy folder"
3. Head to the "mouse over folder" while avoiding moving over the expanded
folders, and hover over that folder so it expands.
4. Move the mouse away from the menu, and the bookmark should be hovering by
itself.

It's also easy to reproduce this without so much skipping around and it seems
to have become much more prominant in recent builds (following the other
comments)

Updated

13 years ago
Keywords: testcase
Assignee: bugs → nobody
QA Contact: chrispetersen → bookmarks

Comment 7

6 years ago
Can't reproduce this with both steps from Comment 0 and Comment 1, reporter, do you still experiencing this problem?
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WFM]

Comment 8

6 years ago
Can't reproduce on SeaMonkey 2.12.1 Windows and Linux versions.
Seems to be fixed at some point.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [2012 Fall Equinox][CLOSEME 2012-11-01 WFM] → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.