Mozilla application shows generic icon on disk image

RESOLVED WORKSFORME

Status

--
trivial
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: orbplus2000, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030415
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030415

The Mozilla package icon that is dragged into the Applications folder does not
have have the M icon like yesterday's build.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Mozilla's package icon was using a Default Application icon instead of the
Mozilla icon.

Expected Results:  
The icon should behave like it did on the MachO 20030414 build.

Comment 1

16 years ago
WorksForMe, the 04-15 build has the expected M application icon.
(Reporter)

Comment 2

16 years ago
There were two builds today.  I was using the 2003041508 (posted around 12:30 or
so).  There was another one at 8 or so.  Which build are you using?

Comment 3

16 years ago
2003041508.
(Reporter)

Comment 4

16 years ago
The problem also shows itself on the 2003041610 MachO.  The icon appears wrong
to me once I unstuff it.  Is it possible this bug has something to do with the
Mac 10.2.5 update that recently came out?

Comment 5

16 years ago
I'm running 10.2.5, and the 0416 build looks fine, too. Does the application not
show an icon on the disk image, either? Are you sure there aren't any problems
with your disk?

Comment 6

16 years ago
Actually, I just downloaded 2003-04-17-03-trunk, not 0416. It looks fine.
(Reporter)

Comment 7

16 years ago
The icon in each of the recent nightlies (including today's) does not show up in
the disk (in the Applications folder) or the mounted disk file (created by
stuff-it expander 7.01).  This problem seems to be connected to the Mac OS
10.2.5 update.  I updated this past weekend, and the icons started being
incorrect.  However, the Mozilla icon in the dock does show up correctly.  Maybe
you could ask Mike Pinkerton about how Camino's icon is able to show up correctly.

Comment 8

16 years ago
I'm running 10.2.5, and recent nightlies look fine. I suspect there may be a
problem with your system.
(Reporter)

Comment 9

16 years ago
I tried unstuffing the nightly build multiple times and tried to get the icon to
show up normally.  One time I was able to get the normal icon to show up after
dragging the package first from the mounted disk to the desktop, then I opened
the GET INFO Mac OS menu.  I then closed the GET INFO Mac OS menu and then
dragged it to the Applications folder.  Suddenly the icon was correct.  I tried
to duplicate this several more times, but was unsuccesful. 

Comment 10

16 years ago
After downloading the 4/19 build, the Mozilla application on the disk image
shows no icon, though the expected mach.icns file is present inside the
application package. Hm.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: mozilla package icon incorrect → Mozilla application shows generic icon on disk image

Comment 11

16 years ago
After logging out of my OS X user account and logging back in, all icons display
as expected, including on the disk image.
Severity: normal → trivial

Comment 12

16 years ago
*** Bug 203284 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.