Form Select with display:block is displayed incorrectly after selection

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Alexander Shpack, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Try this code.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN">
<html>
<head>
 <title>Select Bug</title>

<style type="text/css">
	SELECT{
		width: 150px;
		display: block;
	}
</style>

</head>
<body>
<form action="" method="GET">
 <table width="600">
  <tr>

   <td>
    Select various options one more time.
   </td>
   <td style="background-color: #aaa;">
	 <select>
	  <option>Select me or other option</option>
	  <option>Long size text into option One</option>
	  <option>Long size text into option Two</option>

	  <option>Long size text into option Three</option>
	 </select>
   </td>
  </tr>
 </table>
</form>
</body>
</html>

Reproducible: Always

Steps to Reproduce:
Created attachment 141510 [details]
Reporter's testcase
No clear description of what the problem is, and the display in the testcase is
not changed when I select options (other than showing the new option).... please
reopen if this is still a problem and clearly explain what the problem is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.