Long text/plain lines render partially

RESOLVED DUPLICATE of bug 92193

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 92193
15 years ago
14 years ago

People

(Reporter: Samuli Kärkkäinen, Assigned: roc)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

http://www.kelloseppakoulu.fi/cgi-bin/lines.cgi outputs a text/plain document
that consists of 5 lines, each containing 65536 "x" characters. It pauses for a
second between outputing each line.

Mozilla (and more so Galeon) render the page as if some of the lines were
shorter than 65536 characters, or some x's were whitespace in middle of the
line. When I view the source of the rendered page, it looks okay, so the browser
receives the page correctly, just renders it wrong.

In particular look at the right edge of the page. Often some lines are missing a
few characters. This is repeatable to me.

Happens both with Mozilla-1.3-0_rh8_xft.rpm and latest nightly 2003041508.

The script source is as following:

#!/usr/bin/perl -w
                                                                               
                                                                               
               
print "Content-Type: text/plain\n\n";
for (1 .. 5) {
        print "x" x 65536, "\n";
        sleep 1;
}


Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
I see this too LInux 2003041508

Comment 2

15 years ago
I also see this with linux trunk 20030415.  loading an equivalent text file
locally does not have any problems.  selecting undisplayed text displays it
temporarily, but it generally redisappears.

only one of the 5 lines seems to be necessary.

marking NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase

Comment 3

15 years ago
With Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3.1) Gecko/20030418), I first
see the first line and the last two lines, which appear fully displayed. When I
scroll ight, the 2nd and 3d lines suddenly appear. They don't scroll into view,
they just appear. Scrolling left makes them disappear. At the right edge, all
five lines appear fully formed. This is release candidate 1.3.1

Comment 4

15 years ago
*** Bug 214786 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
I can reproduce this with the output from my SMC router under 0.7+ (Mozilla/5.0
(Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031025 Firebird/0.7+).  The
log is produceed as a single line about 13,000 characters long.  It is not
rendered in the browser (or readily visible in the view source window), but
displays properly in 0.7 itself or in IE.
*** Bug 223957 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
This is a dup of bug 92193.

Comment 8

14 years ago

*** This bug has been marked as a duplicate of 92193 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.