Headers in tables are rendered without additional space.

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
P4
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Volker Seibt, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.3) Gecko/20030312

Headers in tables are rendered without additional space when the table cell
contains only the header. This is done regardless of the border size (1 or 0 in
the example).

Reproducible: Always

Steps to Reproduce:
1. Call the page named in URL.
Actual Results:  
There is no additional space rendered after some headers (see commented sample
page).

Expected Results:  
Render additional space after each header, regardless whether the header is
outside or inside a table.

I know that there is no definition in HTML how to render headers exactly. So we
and others could quarrel a long time about it.

But see:
Older versions of Netscape and the Internet Explorer make no difference of
headers outside and inside a table. So a change of this is not upward compatible
- and I don't see that this change of the interpretation is necessary.
We have an explicit "td > h1:last-node { margin-bottom: 0 }" quirk in quirk.css.
 Netscape 4 indeed does not remove the bottom margin on that testcase; dunno about 
IE.

Perhaps we can remove the quirk?

Comment 2

15 years ago
Created attachment 120751 [details]
testcase

Comment 3

15 years ago
confirming the bug.
IE displays a margin-bottom > 0 in this scenario 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Windows 2000 → All
Priority: -- → P4
Assigning to quirk-meister Ian to make a call.
Assignee: table → ian
Does this affect any high profile sites? If not, I say we leave it, lest we end
up screwing something else up instead.

Note that any tests really should be in strict mode. Quirks mode is best tested
by doing side-by-side comparisons of sites with IE rather than trying to make
sense of test case results.
It sounds like we're being too quirky here, and we should probably remove the
quirk.  Someone should write a testcase to figure out exactly how much to remove.
(Reporter)

Comment 7

15 years ago
Created attachment 132056 [details]
It shows that there is MISSING spacing after a header in a table.

The attachment might be the testcase You are waiting for.
Not really, since we have the quirk for a whole bunch of elements, and that
testcase only helps tell us that we shouldn't have it for H1, not whether we
should have it for any of the others:

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/layout/html/document/src/quirk.css&rev=1.42&mark=149-169#148
(Reporter)

Comment 9

15 years ago
Created attachment 132128 [details]
Headers outside and inside a table

It's complicated. What belongs to the "whole bunch of elements"? I don't
understand the internal code of the named page. (OK - I also don't wont to
understand it. ;-)

What I want is:
(BTW: I'm using borderless tables for formatting purposes. There might be
better ways, but why not use this pretty good feature?)
The horizontal spacing above and below a headline INSIDE a (borderless) table
should be the SAME as OUTSIDE a table.
(Reporter)

Updated

15 years ago
Attachment #132056 - Attachment is obsolete: true

Comment 10

15 years ago
Created attachment 136373 [details]
ie rendering part 1

Comment 11

15 years ago
Created attachment 136374 [details]
ie rendering part 2
Assignee: ian → nobody
QA Contact: madhur → core.layout.tables

Comment 12

9 years ago
this is wfm since 2003
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

9 years ago
this is wfm since 2003 -> this [is] works for me since 2003?

I confirm that it works both with

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
        "http://www.w3.org/TR/html4/strict.dtd">

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
        "http://www.w3.org/TR/html4/loose.dtd">

My testcase was old Netscape standard:

    <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">

Even here the result is near to what I intended, so forget the rest!

After the six years I've find out better ways than writing headers in tables.

(After successing with the test acid 2 fixing for acid 3 is much more important than any quirks actions.)

Thank you all!
You need to log in before you can comment on or make changes to this bug.