Mozilla Pegs CPU at Download

RESOLVED WORKSFORME

Status

()

Core
Networking
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Jerry Baker, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 2008-01-20, URL)

(Reporter)

Description

15 years ago
2003041408 trunk

1. Visit http://www.randmcnally.com and select "Get a Map".
2. Type in a location.
3. If the first load of the map doesn't give you trouble, try resizing the map
or moving the center.

RESULT:
Each time the map page is loaded, Mozilla pegs the CPU for several seconds
during which time the UI is frozen. Status bar reads either "Connecting to
www.randmcnally.com" or "Tranferring data from 192.168.111.2o7.net" (that's
supposed to be 2o7).

Pressing the ESC key immediately after map image loads appears to solve the
problem, and no page elements are visually missing.

Filed under HTTP:Networking due to status bar text when this is occuring.
(Reporter)

Updated

15 years ago

Comment 1

15 years ago
WORKSFORME win2k trunk 2003041416.  Jerry, could you perhaps try creating a new
mozilla profile?  thx!
(Reporter)

Comment 2

15 years ago
That works, but what could be causing that? I'm trying to avoid migrating
profiles as Mozilla makes this *very* difficult.

Comment 3

15 years ago
i'm not exactly sure what could be wrong with your old profile, so we'll have to
take it one step at a time.  perhaps you could upload your prefs.js file to this
bug report or send it directly to me.

Comment 4

14 years ago
Jerry, the file "downloads.rdf" in your profile directory might grow in the
course of time... grow to a point where it contains hundreds and thousends of
entries which makes every download delay a few seconds (there is a bug about that).

I'm not sure if this bug can be caused by that (I don't think so, but you might
still try deleting it - it will make your downloads faster and make the list
displayed in download manager empty/remove all partial downloads, if any), but
it's only one example how a profile can cause problems (other problems include
old installed extensions and themes).
You have already found the problem is caused by your profile, so you might try
to isolate the cause.
I never had to really migrate my Mozilla profile. Removing single files or
extensions cured everything.

I strongly recommend closing this bug (not seen with a new profile), but finding
the reason obviously makes sense.

Comment 5

12 years ago
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking

Comment 6

10 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010705 Minefield/3.0b3pre

do you agree?
Whiteboard: CLOSEME 2008-01-20
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.